Bug 179875 - The refresh of Navigator window is too slow
The refresh of Navigator window is too slow
Status: RESOLVED DUPLICATE of bug 178663
Product: php
Classification: Unclassified
Component: Navigation
6.x
PC Windows XP
: P2 with 1 vote (vote)
: TBD
Assigned To: rmatous
issues@php
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-26 07:40 UTC by jozefh
Modified: 2010-02-03 06:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jozefh 2010-01-26 07:40:01 UTC
When working with large PHP files in editor and switching between them, the Navigator window is "dead" for more then 5 seconds. Is it possible to cache the content of Navigator window?
Reproduce: Download the TCPDF library and open the file tcpdf.php in editor.
http://sourceforge.net/projects/tcpdf/
Comment 1 Tomas Mysik 2010-01-26 07:49:18 UTC
Defect, not enhancement. Radku, please have a look whether anything can be done on PHP side, otherwise reassign. Thanks.
Comment 2 Filip Zamboj 2010-01-26 07:54:34 UTC
Right, it takes more than 8 seconds in my case on build from 2010-01-25. It
takes long each time you switch between larger files (e.g. tcpdf.php). Question
is, is this long in file of 16342 lines of php code?
Comment 3 rmatous 2010-02-03 06:30:22 UTC
Duplicate of #178663

*** This bug has been marked as a duplicate of bug 178663 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo