Bug 179864 - NullPointerException at org.netbeans.api.javafx.source.ElementHandle.create
NullPointerException at org.netbeans.api.javafx.source.ElementHandle.create
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Unsupported
6.x
All All
: P2 (vote)
: 6.x
Assigned To: J Bachorik
issues@javafx
EXCEPTIONS_REPORT,68patch-candidate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-26 04:41 UTC by Alexandr Scherbatiy
Modified: 2010-02-04 04:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.97 KB, text/plain)
2010-01-26 04:41 UTC, Alexandr Scherbatiy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2010-01-26 04:41:45 UTC
Build: NetBeans IDE 6.8 (Build 200912041610)
VM: Java HotSpot(TM) Client VM, 14.1-b02, Java(TM) SE Runtime Environment, 1.6.0_15-b03
OS: Windows XP

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.api.javafx.source.ElementHandle.create(ElementHandle.java:353)
   at org.netbeans.modules.javafx.refactoring.impl.scanners.BaseRefactoringScanner.<init>(BaseRefactoringScanner.java:67)
   at org.netbeans.modules.javafx.refactoring.impl.scanners.BaseRefactoringScanner.<init>(BaseRefactoringScanner.java:75)
   at org.netbeans.modules.javafx.refactoring.impl.scanners.RenameScanner.<init>(RenameScanner.java:67)
   at org.netbeans.modules.javafx.refactoring.impl.plugins.RenameRefactoringPlugin$4.run(RenameRefactoringPlugin.java:383)
   at org.netbeans.modules.javafx.refactoring.impl.plugins.RenameRefactoringPlugin$4.run(RenameRefactoringPlugin.java:380)
Comment 1 Alexandr Scherbatiy 2010-01-26 04:41:49 UTC
Created attachment 93549 [details]
stacktrace
Comment 2 Alexandr Scherbatiy 2010-01-26 04:44:34 UTC
NB 6.8 patch1 2010-01-25_21-27-59

Steps to reproduce:

- Create JavaFX MediaBox sample
- Go to the com.sun.javafx.mediabox.Main file
- Go to the 'var mediaBox: MediaBox = MediaBox {' line
- Refactor -> Rename the MediaBox  to MediaBox2


The exception pops up.
Comment 3 Alexandr Scherbatiy 2010-01-26 05:16:29 UTC
In NB 6.9 NetBeans-JavaFX-Soma:  #129 Jan 26, 2010 12:00:49 AM
I see message "Cannot rename here".
Comment 4 J Bachorik 2010-01-27 06:02:32 UTC
Fixed for patch1
The problem in trunk is still caused by CSS refactoring going crazy - will be resolved once the changes from web-main will be propagated to main-golden
Comment 5 rbalada 2010-01-27 06:36:11 UTC
Fixed in release68_fixes branch after merging TreePathHandle-> ElementLocation
refactoring of "Refactoring".

Please verify in next NB 6.8 fixes build

(Please consider filling this issue once more for tracking of the trunk issue)
Comment 6 Alexandr Scherbatiy 2010-02-04 04:20:22 UTC
verified in NetBeans-JavaFX-Soma: #142


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo