Bug 179763 - createLogicalView (LowPerformance took 6256 ms.)
createLogicalView (LowPerformance took 6256 ms.)
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-21 13:31 UTC by rmartins
Modified: 2010-11-26 06:15 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2010-01-21 13:31 UTC, rmartins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rmartins 2010-01-21 13:31:10 UTC
Build: NetBeans IDE Dev (Build cnd-main-2587-on-100121)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Linux

User Comments:
GUEST: The IDE was started

GUEST: I just started up the IDE.

GUEST: just openning the IDE



Maximum slowness yet reported was 9895 ms, average is 6126
Comment 1 rmartins 2010-01-21 13:31:16 UTC
Created attachment 93464 [details]
nps snapshot
Comment 2 Vladimir Voskresensky 2010-03-16 06:19:49 UTC
Thomas, could you, please, move source/test roots + list of configurations into project.xml.
That give us a chance to make async creation of other logical view content
Comment 3 Vladimir Voskresensky 2010-03-16 06:59:43 UTC
by list of configurations I mean only names, not content.
by source/test roots I mean only folders paths, not content and not items
Comment 4 Thomas Preisler 2010-05-10 21:34:52 UTC
Can't read the nps attachment. What is a nps file?

Fixed what VV requested: source roots are now stored in project.xml and requesting the source groups the through the public interface MakeSources.getSourceGroups(String) will no longer trigger the project descriptor to be read. Also, configuration names are now stored in project.xml.

Not sure fixing these two things is related to the issue here. The first one might. Will close as INVALID. Please reopen with a valid attachment an steps to reproduce.
Comment 5 Quality Engineering 2010-05-11 05:52:56 UTC
Integrated into 'main-golden', will be available in build *201005101712* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/
User: 
Log:
Comment 6 Alexander Simon 2010-05-11 07:06:28 UTC
(In reply to comment #4)
> Can't read the nps attachment. What is a nps file?
Thomas, it is a snap shot produced by Netbeans.
So you can open it by netbeans (netbeans.exe).
Comment 7 Alexander Simon 2010-05-11 07:11:28 UTC
Reopen because EDT wait configuration descriptor about 6 seconds.
Comment 8 Alexander Simon 2010-11-25 16:10:30 UTC
fixed when Bug #191966 was fixed.
Comment 9 Quality Engineering 2010-11-26 06:15:30 UTC
Integrated into 'main-golden', will be available in build *201011260001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/eecafab0eb30
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: extra fixes for #179763: createLogicalView (LowPerformance took 6256 ms.)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo