Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 179761 - [68cat] NoClassDefFoundError: Could not initialize class org.netbeans.api.project.ui.OpenProjects
[68cat] NoClassDefFoundError: Could not initialize class org.netbeans.api.pro...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@editor
EXCEPTIONS_REPORT
:
: 179781 179782 179783 (view as bug list)
Depends on:
Blocks: 179459
  Show dependency treegraph
 
Reported: 2010-01-21 11:11 UTC by alied
Modified: 2010-01-24 08:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.94 KB, text/plain)
2010-01-21 11:11 UTC, alied
Details
stacktrace (1.94 KB, text/plain)
2010-01-21 11:17 UTC, alied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alied 2010-01-21 11:11:32 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-4568-on-091221)
VM: Java HotSpot(TM) Client VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Windows Vista

User Comments:
alied: deleting ergonomics2 does not help




Stacktrace: 
java.lang.NoClassDefFoundError: Could not initialize class org.netbeans.api.project.ui.OpenProjects
   at org.netbeans.modules.cnd.modelutil.CsmUtilities.isAnyNativeProjectOpened(CsmUtilities.java:382)
   at org.netbeans.modules.cnd.navigation.macroview.MacroExpansionAction.isEnabled(MacroExpansionAction.java:88)
   at org.openide.awt.Actions$MenuBridge.updateState(Actions.java:1084)
   at org.openide.awt.Actions.connect(Actions.java:192)
   at org.openide.awt.Actions.connect(Actions.java:159)
   at org.openide.awt.Actions$MenuItem.<init>(Actions.java:1406)
Comment 1 alied 2010-01-21 11:11:37 UTC
Created attachment 93459 [details]
stacktrace
Comment 2 alied 2010-01-21 11:17:44 UTC
Created attachment 93460 [details]
stacktrace

org\netbeans\modules\masterfs\providers\AnnotationProvider.class actually exists in the NetBeans Install dir
Comment 3 Exceptions Reporter 2010-01-21 11:17:55 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=154787
Comment 4 Jesse Glick 2010-01-21 15:27:37 UTC
jlahoda introduced changed masterfs' friend list but failed to push a new version.

org.netbeans.modules.masterfs/2 [2.21 nbms-and-javadoc-4568-on-091221]
org.netbeans.modules.parsing.api/1 [1.30.0.3 3 nbms-and-javadoc-4717-on-100121]

java.lang.ClassNotFoundException: org.netbeans.modules.masterfs.providers.AnnotationProvider starting from ModuleCL@15c07d8[org.netbeans.modules.parsing.api] with possible defining loaders [ModuleCL@facf0b[org.netbeans.modules.masterfs]] and declared parents [ModuleCL@1aae94f[org.netbeans.api.progress], ModuleCL@facf0b[org.netbeans.modules.masterfs], ModuleCL@baa466[org.netbeans.libs.lucene], ModuleCL@137d090[org.openide.windows], ModuleCL@1242b11[org.openide.nodes], ModuleCL@127fa12[org.openide.loaders], ModuleCL@110c31[org.netbeans.modules.lexer], org.netbeans.MainImpl$BootClassLoader@337838, ModuleCL@16acdd1[org.netbeans.modules.editor.lib2], ModuleCL@192c8d9[org.netbeans.modules.projectapi], ModuleCL@16f25a7[org.netbeans.modules.editor.util], ModuleCL@e06940[org.netbeans.modules.queries], ModuleCL@1e232b5[org.netbeans.modules.projectuiapi], ModuleCL@15db314[org.netbeans.modules.editor.mimelookup], ModuleCL@97eded[org.openide.text], ModuleCL@13c6a22[org.netbeans.modules.editor.lib], ModuleCL@165a3c2[org.netbeans.api.java.classpath], ModuleCL@ee6681[org.netbeans.spi.tasklist], ModuleCL@18bbc5a[org.netbeans.modules.editor.settings.storage]]
Comment 5 Jan Lahoda 2010-01-22 03:30:23 UTC
Sorry for that:
http://hg.netbeans.org/jet-main/rev/620c64e88fe7
Comment 6 Jesse Glick 2010-01-22 07:45:25 UTC
*** Bug 179781 has been marked as a duplicate of this bug. ***
Comment 7 Jesse Glick 2010-01-22 07:45:31 UTC
*** Bug 179782 has been marked as a duplicate of this bug. ***
Comment 8 Jesse Glick 2010-01-22 07:45:34 UTC
*** Bug 179783 has been marked as a duplicate of this bug. ***
Comment 9 Quality Engineering 2010-01-24 08:43:11 UTC
Integrated into 'main-golden', will be available in build *201001240200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/620c64e88fe7
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #179761: correcting dependencies (incrementing spec. version of masterfs, and both spec. and impl. version of parsing.api)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo