Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 179566 - Have profiles for code formatting
Have profiles for code formatting
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
:
Depends on: 144579
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-15 13:28 UTC by entonio
Modified: 2016-07-07 07:30 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description entonio 2010-01-15 13:28:32 UTC
Hi,
Often I have to switch between projects with different coding styles. This is hard. I see that you have the option to override the global formatting options per-project, but that is very cumbersome. What I suggest is:

1 - For each language, the ability to create many formatting profiles (to make it even better, the ability to create new profiles by copying an existing one, rather than start always from scratch)
2 - Globally there would be 'megaprofiles', each being a list of associations one-language -> one-per-programming-language-profile
3 - Projects would be changeably associated to a 'megaprofile'
4 - No more definitions for individual projects: if needed, duplicate a megaprofile, duplicate the specific profile one wants to change, and edit the duplicate

Illustrating:

- Given a system with the languages J, C and H (say, Java, CSS, HTML)
- Where the user had 3 different profiles for Java, 2 for CSS and 1 for HTML
- And the default megaprofile (mpX) was J1, C2 and H1
- Another profile (mpY) could be J3, C1 and H1
- J2 would be 'unused' but otherwise would be there
- Project A would use mpX because no one ever changed it
- Project B would use mpY
- Project C needs J2 and C2, so the user creates mpZ by duplicating mpX, then changes mpZ to use J2 instead of J3
- Later on, the user sets mpZ as the default, and no existing project is affected (because the 'default' only matters at creation time), but new projects will be initialised pointing to mpZ

I think this would work very well.
Comment 1 Martin Balin 2016-07-07 07:30:20 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo