Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 179348 - NB 6.8 crashes when opening file browser
NB 6.8 crashes when opening file browser
Status: CLOSED WORKSFORME
Product: platform
Classification: Unclassified
Component: JDK Problems
6.x
PC Windows XP
: P3 (vote)
: 7.0
Assigned To: Antonin Nebuzelsky
issues@platform
jdk_bug_6989652
:
: 180517 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-09 19:48 UTC by Smile-n-Nod
Modified: 2011-11-16 16:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
log file from when IDE crashes (26.39 KB, application/octet-stream)
2010-01-09 19:48 UTC, Smile-n-Nod
Details
File results when File / Open File menu option is selected (11.17 KB, application/octet-stream)
2010-01-11 06:13 UTC, Smile-n-Nod
Details
Crash report for NB6.8 File->Open Project (13.99 KB, text/plain)
2010-05-06 09:45 UTC, stiffuser
Details
Another crash report on 6.8->Open Project (12.54 KB, application/octet-stream)
2010-05-28 01:27 UTC, mtardif
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Smile-n-Nod 2010-01-09 19:48:59 UTC
Created attachment 93152 [details]
log file from when IDE crashes

I'm running a fresh install of NetBeans 6.8 with the latest JVM installed.

After I start up the IDE, the IDE crashes (vanishes from the screen) if I select (1) File menu, Open Project; or (2) File menu, File Open; or (3) select Tools menu, Java Platform, Javadoc, Add ZIP/Folder.   It appears that any file selector box causes the IDE to crash.
Comment 1 Peter Pis 2010-01-11 03:14:16 UTC
It seems that JVM crashes for some reason. Could you please check the NB installation directory for "hs_err_pid*" file? Could you please attach it here, if it exists?
Comment 2 Smile-n-Nod 2010-01-11 06:13:54 UTC
Created attachment 93174 [details]
File results when File / Open File menu option is selected

Here is the log file that NetBeans creates when I select the File menu and then the Open File option (which causes the IDE to disappear).  Both the JVM (version 1.6.0_17) and NetBeans (version 6.8) are fresh installs.  I am running Windows XP SP3.
Comment 3 jpbnet 2010-03-28 10:42:59 UTC
Hi,

I have exactly the same behavior. Is there any tricks available to work around this problem?

Thanks
Comment 4 jpbnet 2010-03-29 17:53:10 UTC
Note that I tried to down grade to NetBeans 6.7 with no luck. Very same behavior. I then installed 6.8 on an other PC with a rather similar configuration and it works fine.

What is the issue? Is it related to firewalls? I read that it could have been an issue with NVIDIA but I upgraded also the driver and did not change the behavior. What else? Any clue?

Thanks.

JP
Comment 5 stiffuser 2010-05-03 21:20:22 UTC
Hi! Apparently it's a problem with JFileChooser 

see here: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6544857
Same issue here:

FIXED:
I updated to java 6.20 (I was using 6.19) and it works fine now !!!!
http://www.java.com/en/download/manual.jsp

Product Version: NetBeans IDE 6.8 (Build 200912041610)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Had problems with File->Open project and any other Browse button inside the ide. Can someone else try and confirm, I only tried it on my machine (XP SP3 Netbeans 6.8)
Comment 6 stiffuser 2010-05-06 09:38:37 UTC
Sorry, after restart it came back. I reinstalled Java, and it was ok then same problem after restart. Maybe it's a java setting with last opened folder somewhere?
Comment 7 stiffuser 2010-05-06 09:45:06 UTC
Created attachment 98552 [details]
Crash report for NB6.8 File->Open Project
Comment 8 mtardif 2010-05-28 01:27:28 UTC
Created attachment 99577 [details]
Another crash report on 6.8->Open Project

I have the exact same issue, no file chooser is working inside the IDE. This was tested with version 6.7.1, 6.8 and 6.9 beta. 

The crash report that I've included seems to be indicating an error similar to the one added by stiffuser...
Comment 9 Antonin Nebuzelsky 2010-10-04 13:46:24 UTC
*** Bug 180517 has been marked as a duplicate of this bug. ***
Comment 10 vaibhavtyagi 2010-10-06 11:17:03 UTC
I was using netbeans 6.9 and Java 7.It was working fine.but now I also have exactly same issue.I reinstalled the Java , but the problem is not solved.
I can't even uninstall netbeans.

Please help me how to solve this problem.
Comment 11 Antonin Nebuzelsky 2010-10-06 13:24:47 UTC
Cannot fix nor workaround in NetBeans code. Closing wontfix with a reference to the JDK bug.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6989652

Increased the priority of the JDK bug now. Expecting comments and resolution from the Java team.
Comment 12 Marian Mirilovic 2011-06-09 17:17:09 UTC
(In reply to comment #11)
> http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6989652
> 
> Increased the priority of the JDK bug now. Expecting comments and resolution
> from the Java team.

Closed as not reproducible ... I would do so here, in case you are still abel to reproduce the problem please add comments here or much better into JDK bug. Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo