Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 179305 - NB 6.8 'renames' Rakefile
NB 6.8 'renames' Rakefile
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Project
6.x
PC Windows XP
: P3 (vote)
: 7.0
Assigned To: Erno Mononen
issues@ruby
69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-08 04:09 UTC by chaukmean
Modified: 2010-07-08 12:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chaukmean 2010-01-08 04:09:36 UTC
NB 6.8 sees rake file named Rakefile as rakefile.

To reproduce the problem :
- create a Ruby project (e.g. named Test with the default JRuby platform)
- just after the creation, the rake file is correctly seen as Rakefile
- exit and restart Netbeans (once or twice)
- the rake file is seen as rakefile

This causes a lot of problems related with version management with e.g. Subversion :
- the rake file is seen as rakefile (and not as Rakefile) and recognized as a 'Locally New' file.
- the commit can be performed but afterwards, the file is again seen as a 'Locally New' file.
- (svn) copy cannot be performed as there is a warning indicating that 'there are locally modified files' !
Comment 1 Erno Mononen 2010-01-08 05:14:58 UTC
Thanks for the report, seems pretty weird. After 20+ attempts I wasn't able to reproduce this though, I tried both w/ and w/o SVN - can you confirm whether you can reproduce this on a project that is not imported into SVN (I'm guessing this might have something to do with SVN)? This may also be Win specific (I tested on Linux only so far).
Comment 2 chaukmean 2010-01-08 05:53:01 UTC
I don't think that the problem is related with SVN.
The problems I have with SVN are consequences of the 'rename'.

Indeed, this can be reproduced with a fresh new project not managed within SVN.
Just create a Ruby project and exit/restart NB.
Sometime, the issue occurs only after a second exit/restart of NB.

Also, from the DOS command line, the file is actually named 'Rakefile'.
But from NB, the file is seen as 'rakefile'.
Comment 3 Erno Mononen 2010-01-08 06:06:11 UTC
OK, thanks for following up. I will need to test this on Win as on Linux this doesn't seem to be reproducible (I will need to setup Win first, so might take some time). Also, can you please paste here the JDK and rest of the info from Help | About? Thanks.
Comment 4 chaukmean 2010-01-08 07:20:01 UTC
I've tried on another WinXP machine (that does not have subversion installed) and I've been able to reproduce the issue.

After the creation of the Ruby project, I've waited for the completion of the scanning of the projects. Then after the first exit/restart of NB, the rake file is seen as rakefile instead of Rakefile.

Here is the requested information :

Product Version: NetBeans IDE 6.8 (Build 200912041610)
Java: 1.6.0_17; Java HotSpot(TM) Client VM 14.3-b01
System: Windows XP version 5.1 running on x86; Cp1252; fr_FR (nb)
Userdir: C:\Documents and Settings\Internet\.netbeans\6.8
Comment 5 chaukmean 2010-01-11 09:17:33 UTC
A follow up for this issue.
I've just tried NB 6.8 on Linux Ubuntu 9.10 and indeed, the problem does not occur.
So, this is definitively a Windows specific issue.
I hope that you will be able to reproduce this issue on a Windows box.
Comment 6 chaukmean 2010-05-31 10:20:11 UTC
Hi,
Could you please fix this specific Windows issue. It is still there with NB6.9 RC1.
It is very annoying as I have to do most of my work on a Windows machine.
Thanks.
Comment 7 Erno Mononen 2010-05-31 13:21:42 UTC
Hi, sorry for the long period of inactivity on this. I was finally able to reproduce the issue after setting up another virtual Win installation. Unfortunately I wasn't able to debug this yet though.
Comment 8 chaukmean 2010-05-31 17:32:44 UTC
I'm glad to know that you have been able to reproduce this issue.
I'm looking forward the fix.
Comment 9 Erno Mononen 2010-06-01 13:01:10 UTC
Should be fixed now in 769b9d7a67a1, please give it a try once the fix makes it into the daily build (there'll be an automatic notification here then). I'll then transplant the fix to 6.9.1.
Comment 10 Quality Engineering 2010-06-03 06:09:39 UTC
Integrated into 'main-golden', will be available in build *201006030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/769b9d7a67a1
User: Erno Mononen <emononen@netbeans.org>
Log: #179305 - NB 6.8 'renames' Rakefile
Comment 11 chaukmean 2010-06-03 11:26:09 UTC
This still does not work with NB*201006030001*.
The issue is still there for both existing projects and new projects.

As a reminder, the simple steps to reproduce :
- creation of a Ruby project
- wait for the completion of the scanning of the projects.
- exit/restart of NB
- the rake file is seen as rakefile instead of Rakefile.
Comment 12 Erno Mononen 2010-06-03 11:49:25 UTC
Hmm, that's weird. After the fix I haven't been able to reproduce the issue with the given steps, maybe the fix didn't really make it into the nightly. Just downloading it to give it a try, will also add logging so that we can know for sure.
Comment 13 Erno Mononen 2010-06-03 12:46:14 UTC
This appears to work for me in 201006030001, but I've made a few additional changes in 0813bed2e2e8 that I believe should fix the issue for good. Please give this a new try once the additional fix makes it into the daily build, and if it still does not work, turn on detailed logging in Tools | Options | Misc | Ruby (I added also logging this time) and attach the log here then. Thanks.
Comment 14 Quality Engineering 2010-06-04 06:08:17 UTC
Integrated into 'main-golden', will be available in build *201006040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0813bed2e2e8
User: Erno Mononen <emononen@netbeans.org>
Log: #179305 (take two) - NB 6.8 'renames' Rakefile
Comment 15 chaukmean 2010-06-04 11:50:37 UTC
This works now with NB*201006040001*.
A big thanks !
Given the minor changes for this fix, could you please include this fix in the upcoming NB6.9 release ?
Comment 16 Erno Mononen 2010-06-04 12:46:01 UTC
If it was up to me I certainly would, but unfortunately I think this won't be accepted for 6.9 - but luckily 6.9.1 is a different story. However, you can safely "patch" your 6.9 FCS (once released) to use the updated versions of the two modules that were affected by the fix, org-netbeans-modules-ruby.jar and org-netbeans-modules-ruby-project.jar in <nb_install_dir>/ruby/modules - just copy those files from NB*201006040001* to 6.9 FCS and restart the IDE. This is safe as there aren't other changes in those modules since the 6.9 clone was created.
Comment 17 chaukmean 2010-06-04 16:47:18 UTC
OK. I understand.
Thanks for the tips for updating the upcoming NB6.9 with this fix.
Comment 18 rbalada 2010-06-16 08:53:11 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 19 chaukmean 2010-06-16 09:54:38 UTC
I've already verified the fix with NB*201006040001* (see Comment#15).
And it works perfectly.
Comment 20 Petr Blaha 2010-06-17 11:51:34 UTC
verified
Comment 21 rbalada 2010-06-21 12:47:20 UTC
main #769b9d7a67a1 transplanted to release691 #6d998719bddb
main #0813bed2e2e8 transplanted to release691 #09d6f464d5ca
Comment 22 Tomas Danek 2010-07-08 12:53:13 UTC
could not reproduce in

Product Version: NetBeans IDE 6.9.1 Dev (Build 201007072301)
Java: 1.6.0_17; Java HotSpot(TM) Client VM 14.3-b01
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Userdir: C:\Documents and Settings\Tomas\.netbeans\6.9.1dev

-->verified in 6.9.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo