Bug 17928 - Method TreeElement.setAttribute() should check if the atrribute name not exist.
Method TreeElement.setAttribute() should check if the atrribute name not exist.
Status: CLOSED DUPLICATE of bug 17699
Product: xml
Classification: Unclassified
Component: TAX
3.x
PC Linux
: P1 (vote)
: 3.x
Assigned To: _ lkramolis
issues@xml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 15:52 UTC by Martin Schovanek
Modified: 2007-09-25 06:05 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2001-11-21 15:52:02 UTC
[jdk1.3.1, Nb Build 200111191655, Linux]

    public static void main(String args[]) throws Exception {
        TreeElement element = new TreeElement("element");
        
        //I can set attribute with existing name.
        element.setAttribute("a", "a");
        element.setAttribute("a", "c");
        element.setAttribute(element.getAttribute("a"));
    }

I think an exception should be thrown.
Comment 1 _ lkramolis 2001-11-21 16:12:17 UTC

*** This issue has been marked as a duplicate of 17699 ***
Comment 2 Quality Engineering 2003-07-02 08:36:06 UTC
Resolved for 3.4.x or earlier, no new info since then -> verify.

Comment 3 Quality Engineering 2003-07-02 08:41:05 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo