Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 179195 - Code completion popup takes too long to appear
Code completion popup takes too long to appear
Status: RESOLVED DUPLICATE of bug 177462
Product: java
Classification: Unclassified
Component: Editor
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-04 08:29 UTC by swpalmer
Modified: 2010-02-11 09:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Snapshot taken during "please wait" when invoking code completion (14.00 KB, application/octet-stream)
2010-01-04 08:31 UTC, swpalmer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swpalmer 2010-01-04 08:29:40 UTC
It takes over two seconds for the popup to appear in a small calls file when I invoked code completion on at the end of the following line in the middle of a code block.

JPanel test = new 

I made sure JPanel was imported and invoked code completion three times to make sure everything was loaded/cached that should be and it still took over two seconds...
I will attach a snapshot.
Comment 1 swpalmer 2010-01-04 08:31:49 UTC
Created attachment 93050 [details]
Snapshot taken during "please wait" when invoking code completion
Comment 2 Dusan Balek 2010-02-11 09:39:42 UTC
Already fixed in the current dev build.

*** This bug has been marked as a duplicate of bug 177462 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo