Bug 179194 - IDE locked up while typing in Java Editor
IDE locked up while typing in Java Editor
Status: RESOLVED DUPLICATE of bug 186324
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
PC Other
: P3 (vote)
: 7.0
Assigned To: Dusan Balek
issues@editor
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-04 08:04 UTC by rptmaestro
Modified: 2010-10-22 15:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (19.72 KB, text/plain)
2010-01-04 08:04 UTC, rptmaestro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rptmaestro 2010-01-04 08:04:29 UTC
Created attachment 93049 [details]
Thread dump

Thread dump attached. The IDE completely froze up and CPU usage maxed out while editing a source file in a Maven web application
Comment 1 Vitezslav Stejskal 2010-01-06 07:46:03 UTC
It looks like a deadlock between "AWT-EventQueue-1" and "Parsing & Indexing Loop (200912041610)". The AWT thread performs BaseKit$DefaultKeyTypedAction which write-locks the document and then through TextRegionManager and JavaCodeTemplateProcessor tries to run a userActionTask. At the same time there is some other userActionTask running, which tries to read-lock the document.

AFAIR the policy is to first lock the parser and then a document. So Strictly speaking the code running in AWT is at fault here. However, I have no idea how to fix the DefaultKeyTypedAction....
Comment 2 David Strupl 2010-10-11 15:19:03 UTC
The only place that came to my mind where to fix this is CodeTemplateInsertHandler.notifyParameterUpdate
by posting the call to 
processor.parameterValueChanged
into its own runnable in AWT.

After consulting with Mila I did not apply this change and I am passing to Dusan to evaluate whether it is really necessary to call runWhenScanFinished from getProposedValue(JavaCodeTemplateProcessor).
Comment 3 David Strupl 2010-10-22 08:23:54 UTC
Dusane, can you please have a look at this one?
Comment 4 Dusan Balek 2010-10-22 15:22:44 UTC
Already fixed.

*** This bug has been marked as a duplicate of bug 186324 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo