Bug 179142 - NetBeans projects cannot be nicely wrapped as a NetBeans module
NetBeans projects cannot be nicely wrapped as a NetBeans module
Status: RESOLVED DUPLICATE of bug 70894
Product: apisupport
Classification: Unclassified
Component: Templates
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-31 09:32 UTC by wobster
Modified: 2010-02-03 21:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wobster 2009-12-31 09:32:42 UTC
There seems to be a huge disconnect between a standard NetBeans project and a NetBeans module. The only way to include the product of a project is to wrap the library as a NB module. Unfortunately, without hacking up the project files by hand, the sources and other project dependencies are lost during this wrapping and the output jar has to continuously copied to the wrapped library module. 

I would like to see an option to wrap a NetBeans project as a NetBeans Module. With this option the project sources would be available and the library would be dependent on the NetBeans project for updates. Ideally there would be an option to include other dependent jars in the project in the library as well "ext" directory.

The goal should be to make it easy to wrap a project as a NetBeans library module. (Currently, it is more ideal to develop using the "project" since the "run" function is disabled in modules.)
Comment 1 Jesse Glick 2010-02-03 16:45:50 UTC

*** This bug has been marked as a duplicate of bug 70894 ***
Comment 2 wobster 2010-02-03 19:31:36 UTC
I don't think this is a duplicate of the other bug since he wanted a more general capability. I want to work within the established NetBeans projects framework. NetBeans modules should be able to eat the NetBeans "dog food" right?

I was basically asking to just automate the hand modified procedure documented in the Wiki.
Comment 3 Jesse Glick 2010-02-03 21:30:24 UTC
That's exactly what bug #70894 is about.

*** This bug has been marked as a duplicate of bug 70894 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo