Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178989 - code completion in beans.xml could list @Alternative classes
code completion in beans.xml could list @Alternative classes
Status: RESOLVED DUPLICATE of bug 229795
Product: javaee
Classification: Unclassified
Component: CDI
7.2
All All
: P4 (vote)
: TBD
Assigned To: Denis Anisimov
issues@javaee
http://www.andygibson.net/blog/index....
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-22 14:23 UTC by David Konecny
Modified: 2013-07-09 16:36 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Konecny 2009-12-22 14:23:28 UTC
Just an idea for future (P4 for now). Read above mentioned blog post and you will find that it could be useful if code completion listed all classes annotated with @Alternative in following beans.xml file ('|' is editor caret):

    <beans>
        <alternatives>  
            <class>|</class>  
        </alternatives>  
    </beans>
Comment 1 abien 2012-04-24 18:34:16 UTC
Great Idea!

In addition:

Implement code completion of the fully qualified name for all classes in persistence.xml and beans.xml in general. Not only @Alternatives but also @Stereotypes and code completion for interceptors should be supported.

I would support the expansion of FQN in all xml files.
Comment 2 Sergey Petrov 2013-07-09 16:36:30 UTC

*** This bug has been marked as a duplicate of bug 229795 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo