Bug 178882 - support C/C++ documentation tool Doxygen
support C/C++ documentation tool Doxygen
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Thomas Preisler
issues@cnd
http://wiki.netbeans.org/CND69Doxygen
:
: 125903 143381 (view as bug list)
Depends on:
Blocks: 122061
  Show dependency treegraph
 
Reported: 2009-12-18 16:27 UTC by Thomas Preisler
Modified: 2010-06-01 20:56 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Preisler 2009-12-18 16:27:55 UTC
Support popular C/C++ documentation tool Doxygen. 

NB 6.9 plans: http://wiki.netbeans.org/CND69Doxygen
Comment 1 Alexander Simon 2009-12-20 02:47:59 UTC
See also #171326
Comment 2 Quality Engineering 2010-02-21 22:28:58 UTC
Integrated into 'main-golden', will be available in build *201002220200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/6d4e76c05d67
User: Thomas Preisler <thp@netbeans.org>
Log: #178882 support C/C++ documentation tool Doxygen
3rd cut...
Comment 3 Quality Engineering 2010-02-23 22:06:24 UTC
Integrated into 'main-golden', will be available in build *201002240200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e0e110f49fd8
User: Thomas Preisler <thp@netbeans.org>
Log: #178882 support C/C++ documentation tool Doxygen
Improved Doxygen template
Comment 4 Quality Engineering 2010-02-26 11:18:15 UTC
Integrated into 'main-golden', will be available in build *201002261426* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/68b44200de40
User: Thomas Preisler <thp@netbeans.org>
Log: #178882 support C/C++ documentation tool Doxygen
working on new Man2HTML...
Comment 5 Thomas Preisler 2010-03-17 17:35:14 UTC
Basic feature implemented.
Comment 6 Alexey Vladykin 2010-05-05 10:11:18 UTC
*** Bug 125903 has been marked as a duplicate of this bug. ***
Comment 7 kexik 2010-05-07 03:10:25 UTC
Thanks for this feature, very helpful.
/** */ works good, but what about shorter "///" ?
These are used when description is enough like:

/// Returns number of monkeys inside box
unsigned int getNumMonkeys();
Comment 8 Alexey Vladykin 2010-05-21 07:23:28 UTC
*** Bug 143381 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Preisler 2010-06-01 20:56:36 UTC
Consider this fixed (in 6.9).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo