Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178852 - ClassCastException: org.netbeans.modules.viewmodel.TreeModelNode$MyProperty cannot be cast to org.openide.explorer.view.VisualizerNode
ClassCastException: org.netbeans.modules.viewmodel.TreeModelNode$MyProperty c...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
EXCEPTIONS_REPORT 68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 07:15 UTC by Alexander Pepin
Modified: 2010-01-28 04:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.33 KB, text/plain)
2009-12-18 07:15 UTC, Alexander Pepin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2009-12-18 07:15:34 UTC
Build: NetBeans IDE 6.8 (Build 200912041610)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Linux, 2.6.28-15-generic, i386

User Comments:
apepin: Steps to reproduce:
- create application
- set a breakpoint 
- start debugger
- open Sessions view
- move any colummn in the first place instead of Name
- double click on cell (0,0) in the table
Result: exception occurs



Stacktrace: 
java.lang.ClassCastException: org.netbeans.modules.viewmodel.TreeModelNode$MyProperty cannot be cast to org.openide.explorer.view.VisualizerNode
   at org.openide.explorer.view.Visualizer.findNode(Visualizer.java:87)
   at org.openide.explorer.view.OutlineView$OutlineViewOutline.editCellAt(OutlineView.java:925)
   at javax.swing.plaf.basic.BasicTableUI$Handler.adjustSelection(BasicTableUI.java:1084)
   at javax.swing.plaf.basic.BasicTableUI$Handler.mousePressed(BasicTableUI.java:1014)
   at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:263)
   at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:262)
Comment 1 Alexander Pepin 2009-12-18 07:15:39 UTC
Created attachment 92758 [details]
stacktrace
Comment 2 Alexander Pepin 2009-12-18 07:24:48 UTC
This happens in all debugging windows.
IMO it should be fixed in 6.8 patch 1.
Comment 3 Jiri Rechtacek 2009-12-18 07:28:46 UTC
Martin, do you know this problem?
Comment 4 Martin Entlicher 2009-12-18 08:47:50 UTC
I have not seen this yet.
It was introduced by the fix of bug #174433.

It looks like the condition "if (column == 0) {" is wrong. When the nodes column is not the first one, it does not work. The correct would be to call Outline.isTreeColumnIndex(column) which would need to be protected, or something like that...
Comment 5 Jiri Rechtacek 2009-12-21 07:40:13 UTC
core-main/rev/5d8dadca6600
Comment 6 Jiri Rechtacek 2009-12-21 07:40:45 UTC
core-main/rev/5d8dadca6600
Comment 7 Quality Engineering 2009-12-21 23:40:38 UTC
Integrated into 'main-golden', will be available in build *200912220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5d8dadca6600
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #178852: ClassCastException: org.netbeans.modules.viewmodel.TreeModelNode$MyProperty cannot be cast to org.openide.explorer.view.VisualizerNode
Comment 8 Tomas Danek 2010-01-18 07:35:48 UTC
was  not able to reproduce using those steps in Product Version: NetBeans IDE Dev (Build 201001150201)
Java: 1.6.0_17; Java HotSpot(TM) 64-Bit Server VM 14.3-b01-101
System: Mac OS X version 10.6.2 running on x86_64; MacRoman; en_US (nb)
Userdir: /Users/tomas/.netbeans/dev


Verified.
Comment 9 pgebauer 2010-01-19 07:49:50 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/790fdc18f866
Comment 10 Alexander Pepin 2010-01-28 04:23:14 UTC
verified in patch1 build 20100128


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo