Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178844 - Maven samples are missing correct javaee6 dependencies
Maven samples are missing correct javaee6 dependencies
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
PC Windows Vista
: P2 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@projects
68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 06:21 UTC by Jaroslav Pospisil
Modified: 2010-01-27 03:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2009-12-18 06:21:10 UTC
Your project has dependencies that are not resolved locally. Code completion in the IDE will not include classes from these dependencies or their transitive dependencies (unless they are among the open projects).
Please download the dependencies, or install them manually, if not available remotely.

The artifacts are:
 javax:javaee-web-api:jar:6.0-SNAPSHOT

Problem caused by change of JavaEE6 libraries version - need to be corrected.
Comment 1 Milan Kuchtiak 2009-12-21 02:47:35 UTC
Fixed.

Details:
http://hg.netbeans.org/main/rev/1fb47bc6c1c1
Comment 2 Quality Engineering 2009-12-21 23:39:27 UTC
Integrated into 'main-golden', will be available in build *200912220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1fb47bc6c1c1
User: mkuchtiak@netbeans.org
Log: #178844: setting proper dependency to JavaEE6 APIs
Comment 3 Jaroslav Pospisil 2010-01-07 03:23:48 UTC
v.
Comment 4 pgebauer 2010-01-14 03:50:21 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/ee0ab0ab2515


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo