Bug 178839 - WS client generation fails because of missing targets in build-impl.xml
WS client generation fails because of missing targets in build-impl.xml
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: JAX-WS
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
68patch-candidate
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 03:54 UTC by Milan Kuchtiak
Modified: 2010-05-20 12:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kuchtiak 2009-12-18 03:54:26 UTC
Steps to reproduce:
1. Download and start Netbeans 6.8 (1.st time with clean userdir) 
2. create new J2SE Project
3. add Web Service client

The project can not be build because :
- build script doesn't contain wsimport-client-XXX target.

Evaluation:

this is related to ergonomics functionality :

1. WS client requires to have jaxws-build.xml file
2. jaxws-build.xml file creation listens on jax-ws.xml changes
3. the jax-ws.xml listener is initialized in project-open time
4. the listener code is located in NB Enterprise Cluster that is not initialized in project-open time.

The workaround for now is to close and open the project when this happens.
However, it would be nice to fix this for 6.8 path.
Comment 1 Milan Kuchtiak 2010-03-29 13:01:57 UTC
Fixed.

Details:
http://hg.netbeans.org/main/rev/1096a3fc74fb
Comment 2 Quality Engineering 2010-04-02 05:08:49 UTC
Integrated into 'main-golden', will be available in build *201004020200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1096a3fc74fb
User: mkuchtiak@netbeans.org
Log: #178839: move jax-ws.xml creation listener from project's open hook, creating JaxWsBuildScriptExtensionProvider
Comment 3 Jaroslav Pospisil 2010-05-20 12:22:54 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo