Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178650 - Relative URL is not displayed from nbactions.xml
Relative URL is not displayed from nbactions.xml
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 7.1
Assigned To: Martin Janicek
issues@javaee
:
: 187244 204472 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-15 04:54 UTC by zoltan.puskai
Modified: 2011-11-22 09:34 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zoltan.puskai 2009-12-15 04:54:44 UTC
6.8 version is saving the 'Relative URL' in the nbactions.xml, but it does not display it again in the Project Properties (Run).

How to reproduce:

Create a new Maven Web Application project.

Set the Relative URL int the Project/Properties/Run.
Close the Project/Properties, open it again (the Relative URL is not filled).

Remarks:
The application will start with the relative Url.
Comment 1 rptmaestro 2010-10-22 16:05:12 UTC
*** Bug 187244 has been marked as a duplicate of this bug. ***
Comment 2 rptmaestro 2010-10-22 16:08:03 UTC
This is particularly confusing when you want to reset the "Relative URL" to a blank value, because it is always blank when you go into the project properties, so it will *not* save the blank value. You have to set it to something else, like '/'
Comment 3 Martin Janicek 2011-11-02 08:49:56 UTC
*** Bug 204472 has been marked as a duplicate of this bug. ***
Comment 4 Martin Janicek 2011-11-02 08:50:49 UTC
This is still valid issue --> TM = 7.1
Comment 5 Martin Janicek 2011-11-03 16:09:17 UTC
Fixed in: http://hg.netbeans.org/web-main/rev/b243b4818348
Comment 6 Quality Engineering 2011-11-04 15:01:34 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/b243b4818348
User: Martin Janicek <mjanicek@netbeans.org>
Log: #178650 - Relative URL is not displayed from nbactions.xml


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo