Bug 178588 - AWT thread blocked for 21817 ms.
AWT thread blocked for 21817 ms.
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@projects
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-14 06:14 UTC by Exceptions Reporter
Modified: 2012-03-21 13:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-12-14 06:14 UTC, Exceptions Reporter
Details
screenshot (212.40 KB, image/png)
2012-03-21 13:18 UTC, Milos Kleint
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2009-12-14 06:14:52 UTC
Build: NetBeans IDE 6.8 (Build 200912041610)
VM: Java HotSpot(TM) Client VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Windows Vista, 6.0, x86

User Comments:
GUEST: Just editing a pom file


Maximum slowness yet reported was 21817 ms, average is 8201
Comment 1 Exceptions Reporter 2009-12-14 06:14:58 UTC
Created attachment 92526 [details]
nps snapshot
Comment 2 Antonin Nebuzelsky 2010-07-30 15:17:58 UTC
Reassigning to default owner.
Comment 3 Milos Kleint 2012-03-21 13:18:39 UTC
Created attachment 117009 [details]
screenshot
Comment 4 Milos Kleint 2012-03-21 13:23:30 UTC
various calls to M2AuxilaryConfigImpl which all eventually hang in File.lastModified() code.

last exception report from 2010, I don't see ways of improving the codebase, could have been caused by external processes..

closing as wontfix


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo