Bug 178553 - I18N : regression - scrolling happens at committing Japanese strings by IME
I18N : regression - scrolling happens at committing Japanese strings by IME
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
All All
: P2 with 3 votes (vote)
: 6.x
Assigned To: issues@editor
issues@editor
68patch-candidate
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-13 19:55 UTC by Masaki Katakai
Modified: 2010-03-20 05:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
movie for the issue (615.50 KB, application/x-zip-compressed)
2009-12-13 19:59 UTC, Masaki Katakai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Masaki Katakai 2009-12-13 19:55:03 UTC
NetBeans IDE 6.8 (Build 200912041610)
Java: 1.6.0_17; Java HotSpot(TM) 64-Bit Server VM 14.3-b01-101
Mac OS X 10.5.8; SJIS; ja_JP (nb)

1. Start NetBeans
2. Open project and edit some codes on NetBeans Editor
   codes need to have enough lines so that scrollbar is visible.
3. turn input method (e.g. ctrl+space or shift+space for opensolaris)
4. enter some text
5. hit return to commit the text
6. the line position of current cursor will move down
   even by hitting return key, the position should stay.

This behavior didn't happen on NetBeans 6.8 Beta. So some changes after Beta is causing this issue.

Please evaluate. I think this happens in other languages which is using IME. We need to prepare a fix in the 1st patch.
Comment 1 Masaki Katakai 2009-12-13 19:59:07 UTC
Created attachment 92486 [details]
movie for the issue
Comment 2 BurakUeda 2009-12-14 22:35:47 UTC
I have same problem here.
Every time I enter a Japanese text, coding screen tilts.
Extremely annoying.
Comment 3 Vitezslav Stejskal 2009-12-15 03:46:18 UTC
Mila, any idea what's wrong here? Thanks
Comment 4 toby_net 2009-12-26 23:34:34 UTC
I'm Japanese user. Almost same proble occurs in windows version too.

When I input Japanese words at Japanese Input Method(ex Microsoft IME or Google IME(Google日本語)), 
An edit area warps and warps with up and down instantaneously.

どうしてこうなった?(It means "How did this happen?" in Japanese.)
Comment 5 Miloslav Metelka 2010-01-12 10:36:22 UTC
It could possibly caused by fix of issue #161701. I'll check that.
Comment 6 Masaki Katakai 2010-01-15 05:51:18 UTC
Adding 68patch-candidate.

Regression from 6.7. 100% reproducible whenever user is typing Japanese on editor for all platforms. I'm seeing many users are complaining in their blogs and tweets.
Comment 7 takakura 2010-01-30 05:59:45 UTC
I checked the fix of issue #161701. 

The cause of this bug is the modified the line 682 in the org.netbeans.editor.BaseCaret source file(changeset: a99f19922716).

When I hit enter key to commit composing text, The Y position of caretBounds was 0. 
So the position of the caret moved.

But I have  no idea to fix this bug.
Please fix this bug and release 6.8 patch.
Comment 8 Vitezslav Stejskal 2010-02-01 09:02:54 UTC
(In reply to comment #7)
> I checked the fix of issue #161701. 
> 
> The cause of this bug is the modified the line 682 in the
> org.netbeans.editor.BaseCaret source file(changeset: a99f19922716).
> 
> When I hit enter key to commit composing text, The Y position of caretBounds
> was 0. 
> So the position of the caret moved.

Thanks
Comment 9 Vitezslav Stejskal 2010-03-17 13:52:24 UTC
http://hg.netbeans.org/jet-main/rev/713c2c5506cd
Comment 10 takakura 2010-03-20 05:11:18 UTC
I confirmed it works well on Windws XP(MS IME, Google IME(Google 日本語入力)), Mac OS X(ことえり, Google IME(Google 日本語入力)) and Ubuntu(IBus).
Thank you Vitezslav!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo