Bug 178482 - Symfony integration does not work if change "Web Root" dir to something like NOT "web"
Symfony integration does not work if change "Web Root" dir to something like ...
Status: RESOLVED DUPLICATE of bug 170775
Product: php
Classification: Unclassified
Component: Symfony
6.x
PC Windows 7
: P3 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-11 07:38 UTC by vsamoletov
Modified: 2009-12-11 09:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vsamoletov 2009-12-11 07:38:02 UTC
Hi all!

By default "Web Root" dir for symfony projects is "web" folder.
But symfony framework allows to configure "Web Root" dir. 
So I can use something like "htdocs" folder as my default "Web Root" dir.

But when I switch to my custom folder netbeans symfony integration brakes.
Nothing happens if I run netbeans action "Symfony: Run command..." or "Symfony: Clear Cache...".
If right click on the project, "Symfony" submenu does not exists. 

Steps to reproduce: 
1. Create new php project with symfony support as usual.
2. Right click on the project and select "Symfony" > "Clear Cache".
3. Right click on the "web" folder and select "Rename...", rename it into "htdocs" or something other.
4. Right click on the project and select "Symfony" > "Clear Cache".:

Expected result: 
Symfony submenu exists I can select it. 
Also I can run netbeans action "Symfony: Run command..." or "Symfony: Clear Cache".

Actual result: 
Symfony submenu does not exists. 
Nothing happens if I run netbeans action "Symfony: Run command..." or "Symfony: Clear Cache".

-----

Also I try to go to project properties and change "Web Root" dir, but problem exists.

Problem was fixed when I create empty folder named "web".
Comment 1 vsamoletov 2009-12-11 07:39:48 UTC
Product Version: NetBeans IDE 6.8 (Build 200912091457)
Java: 1.6.0_17; Java HotSpot(TM) Client VM 14.3-b01
System: Windows 7 version 6.1 running on x86; Cp1251; uk_UA (nb)
Comment 2 Tomas Mysik 2009-12-11 09:42:29 UTC

*** This bug has been marked as a duplicate of bug 170775 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo