Bug 178453 - X11 freeze dragging window
X11 freeze dragging window
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
jdk_bug_6397447
: THREAD
Depends on:
Blocks: 60142
  Show dependency treegraph
 
Reported: 2009-12-10 15:39 UTC by Jesse Glick
Modified: 2010-11-01 18:15 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (after kill -TERM but was similar before) (12.22 KB, text/plain)
2009-12-10 15:39 UTC, Jesse Glick
Details
the same, the next time I tried to reorder tabs... guess I will just stop trying? (29.82 KB, text/plain)
2009-12-10 16:33 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2009-12-10 15:39:56 UTC
Created attachment 92398 [details]
Thread dump (after kill -TERM but was similar before)

I tried to drag an editor tab to another position. The whole desktop (not just NB) froze. I had to kill -9 the IDE from a console login (kill -TERM did not work). JDK 6u17, Ubuntu 9.10 w/ Gnome, NB dev running w/ Ocean L&F.
Comment 1 Jesse Glick 2009-12-10 16:33:56 UTC
Created attachment 92399 [details]
the same, the next time I tried to reorder tabs... guess I will just stop trying?
Comment 2 Stanislav Aubrecht 2009-12-11 00:39:12 UTC
does it help if you uncheck 'drag window image' under tools - options - misc - appearance?
Comment 3 Jesse Glick 2009-12-11 08:25:50 UTC
No, still freezes the same way.

Can't consider this random since it freezes every time I try to drag windows, it seems. Recent change in NB? In JDK? In X11? I don't know.
Comment 4 Stanislav Aubrecht 2009-12-11 08:54:45 UTC
works for me in vboxed ubuntu 9.10, jdk 1.6.0_17, x64
Comment 5 Jesse Glick 2009-12-11 08:59:00 UTC
Not surprising. I have no idea how to go about reproducing in a different environment.
Comment 6 Marian Petras 2009-12-11 14:01:39 UTC
See https://netbeans.org/bugzilla/show_bug.cgi?id=60142#c20 for more information on the cause of the bug.
Comment 7 Jesse Glick 2009-12-14 16:31:51 UTC
I can reproduce using that test application. I run Ubuntu 9.10 (all updates), Gnome, JDK 6u17, a single 1400x1050 display, NVIDIA driver version 185.
Comment 8 Jesse Glick 2009-12-14 16:36:50 UTC
We should get escalated. It's marked P4, which does not sound right for an unrecoverable freeze.
Comment 9 Jesse Glick 2010-01-15 13:01:56 UTC
This bug completely prevents me from using D&D on my Ubuntu system unless I pass --nosplash. Probably the use of the early splash screen should just be disabled on X11 systems until the JDK bug is fixed and widely deployed.
Comment 10 Jaroslav Tulach 2010-01-16 12:44:03 UTC
OK. Let's disable this on Unixes: core-main#0d600a0c79a3
Comment 11 Quality Engineering 2010-01-16 23:28:58 UTC
Integrated into 'main-golden', will be available in build *201001170201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0d600a0c79a3
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #178453: Reverting back to b7bd22f6ea9c: Don't use -splash until fixes on X11
Comment 12 Antonin Nebuzelsky 2010-11-01 17:46:34 UTC
The JDK bug is marked fixed in 6u21:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6397447

Is someone able to reproduce the problem on Linux with an older JDK?

I was trying the test application attached to issue 60142#c21 but I don't encounter the freeze so I cannot verify the fix with 6u21+.
Comment 13 Jesse Glick 2010-11-01 18:08:09 UTC
(In reply to comment #12)
> Is someone able to reproduce the problem on Linux with an older JDK?

Did you try doing so after reverting 0d600a0c79a3?
Comment 14 Antonin Nebuzelsky 2010-11-01 18:15:17 UTC
> Did you try doing so after reverting 0d600a0c79a3?

I was only playing with the test application attached to the other bug (as linked above) which I assume is a self-contained test case.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo