Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178423 - Build script bails with "Cycle Detected" when executing multiple targets
Build script bails with "Cycle Detected" when executing multiple targets
Status: RESOLVED DUPLICATE of bug 174799
Product: projects
Classification: Unclassified
Component: Ant Project
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: Milan Kubec
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-10 06:14 UTC by jesterfred
Modified: 2009-12-10 06:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jesterfred 2009-12-10 06:14:39 UTC
Create an ant based project then try this from the command line:

ant compile test

It will fail with

.../build-impl.xml:381: Cycle detected: ProjectName was already built

You can, however, run the targets in separate invocations thusly:

ant compile
ant test

I use Hudson to maintain all my projects.  This change in behavior broke my Hudson configurations and requires that I invoke each ant target in a separate invocation.  This slows things down dramatically.
Comment 1 Jesse Glick 2009-12-10 06:31:07 UTC

*** This bug has been marked as a duplicate of bug 174799 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo