Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178176 - will not display ejbs in project tab
will not display ejbs in project tab
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: EJB Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Andrey Yamkovoy
issues@javaee
68patch1-verified
: REGRESSION
: 178319 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-04 17:05 UTC by emiddio
Modified: 2010-01-20 06:58 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
zip file of ejb project will not show ejb beans in project (11.08 KB, application/octet-stream)
2009-12-04 17:05 UTC, emiddio
Details
zip of ejb project (166.95 KB, application/octet-stream)
2009-12-05 01:36 UTC, emiddio
Details
illustrative patch (1.12 KB, patch)
2009-12-06 17:50 UTC, David Konecny
Details | Diff
show issue (513.47 KB, image/jpeg)
2009-12-07 21:07 UTC, emiddio
Details
shows issue (547.99 KB, image/jpeg)
2009-12-07 21:08 UTC, emiddio
Details
NBM with fix for NB 6.8 (53.39 KB, application/octet-stream)
2009-12-08 05:46 UTC, Andrey Yamkovoy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description emiddio 2009-12-04 17:05:06 UTC
Created attachment 92162 [details]
zip file of ejb project will not show ejb beans in project

this worked up to 68M2; broke in 68RC1;

attached file project zip - to save space will not build;
just use project to open inside netbeans.

project will not show ejb beans in 68rc2 if opened.

will show beans in 68M2 or earlier netbeans releases

is set to P1 --want fixed in 68release -not pushed out to nb6.9
Comment 1 _ ludo 2009-12-04 18:40:17 UTC
the zip file does not contain the project src code, only the project metadata...
Also complaining abotu jax-rpc module?
Comment 2 emiddio 2009-12-04 22:02:08 UTC
the project has been limited to enough to demonstrate the issue; it will not build; i deleted library references etc to confirm a stripped down project
was still valid to show the issue. after i did that i created a zip;

again i just verified the submitted zip to show the issue.

some of the ejbs source code comes from library includes which does not show methods in the submitted zip; but the beans still show up;

no beans show up in nb68RC[12]


with nb68M2 or nb671 or nb651 when you open the project you can click on the
enterprise beans node of the projects tab and it will show the ejb's in the project.

with nb68rc2 or nb68rc1 it will not;

if you need a complete project i can zip that up also;

i do not get any visible complaints opening the project;

i just now unziped the zip to a completely unrelated directory and all is as i reported.

you should open the project with an earlier version of netbeans to see how it looks there;

the project builds and run properly with nb68rc2 and earlier when deployed to
glassfish v2ur2; but i cannot see beans or baan mehthods or bean cmp/cmr info
in the projects/enterprise tab with nb68RC[12] --i can with earlier versions.
Comment 3 emiddio 2009-12-04 22:04:54 UTC
also with nb68rc[12] i get netbeans exception which are reported by the auto-reporter -- at times; not every time.
Comment 4 _ ludo 2009-12-04 22:24:43 UTC
the zip contains ref to 

file.reference.src-conf=C:\\Sun\\adventure1.0.5\\project4\\apps\\opc\\opc-ejb\\src\\conf
file.reference.src-java=C:\\Sun\\adventure1.0.5\\project4\\apps\\opc\\opc-ejb\\src\\java
and this content is *not* in the zip file...


see the nbproject/private/private.properties file
Comment 5 emiddio 2009-12-05 01:36:50 UTC
Created attachment 92165 [details]
zip of ejb project
Comment 6 emiddio 2009-12-05 01:37:49 UTC
sorry for the mistake -- new zip should suffice
Comment 7 emiddio 2009-12-05 01:57:19 UTC
all needed references should be in the zip; from within netbeans it appears
all references are local to the tree rooted at the project.

but nbproject/private/private.properties still has a number of absolute
references;

not sure why/how they got there -- or why they are still there.

project properties show conf dir as in the project tree;

also shows src dir -- 1 dir -- as rooted at project tree

i was working with an existing project that was working -- from may/08;

i did not try to import this project into netbeans6.8 -- ie. remove project
metadata and create a fresh ejb-project with web services/clients;

its been a couple of years -- but last i tried -- projects that contain
webservices -- clients or services dont import easily into projects -- i had to do a bunch of tricks to get web service/clients recognized in past.
Comment 8 David Konecny 2009-12-06 17:49:18 UTC
Confirmed. I'm not sure there is a time to fix this for 68. Could be a patch release for 68.
Comment 9 David Konecny 2009-12-06 17:50:25 UTC
Created attachment 92193 [details]
illustrative patch

Expanding 'Enterprise Beans' node in a project which contains at least one Session EJB *which is also* WebService will result in NullPointerException in org.openide.nodes.EntrySupport and consequently no EJBs will be shown. It is a regression caused by fix http://hg.netbeans.org/main-golden/rev/17e3d72667e2 - returning "new Node[1]" at the bottom of the changeset is wrong. There is no workaround for this issue. Fix is quite obvious: see attached patch.

There is couple of things in this code which would be worth improving:

* if protected createNodes method is called directly then created node is not cached

* access to nodesHash property is not synchronized despite being modified from different threads
Comment 10 Petr Jiricka 2009-12-07 03:31:32 UTC
This is pretty nasty, should be fixed in a patch. Based on a discussion with QE, this is not a stopper for 6.8, downgrading to P2.
Comment 11 Andrey Yamkovoy 2009-12-07 05:43:32 UTC
David, thanks for the evaluation. I have pushed the patch you provided with some improving changes you mentioned.

Fixed in the web-main.
Comment 12 David Konecny 2009-12-07 12:46:05 UTC
Andrey, could you please consider rebuilding relevant module from release68 branch (if you still have the checkout) with patch applied and attached the built module to this issue. That would allow emiddio or other users to just patch their 68 FCS build till official patch is available.
Comment 13 emiddio 2009-12-07 21:00:04 UTC
added 2 attachments; another possible issue with this issue;

i open project opc-ejb with both nb68M2, and nb68rc2;

all files have been compiled with nb68rc2 -- but some show as needed to
be compiled. the example shows one -- it will compile if project is compiled,

yet never shows not needing to be compiled. F9 compile file always fails.

with NB68M2 -- the same project -- the files show as compiled, also
F9 succeeds without any errors.

2 screen shot to be attached
Comment 14 emiddio 2009-12-07 21:07:33 UTC
Created attachment 92243 [details]
show issue
Comment 15 emiddio 2009-12-07 21:08:46 UTC
Created attachment 92245 [details]
shows issue
Comment 16 emiddio 2009-12-07 21:10:43 UTC
just added 2 attachments

see comment #13

i will download dev build to test with lots of ejb projects that use
webservices -- both clients, services;

does current dev build contain fix?

i see a 20091207 build is available.
Comment 17 Quality Engineering 2009-12-08 02:26:54 UTC
Integrated into 'main-golden', will be available in build *200912080200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/312296fdcbe3
User: Andrey Yamkovoy <kaktus@netbeans.org>
Log: #178176 - will not display ejbs in project tab
Comment 18 Andrey Yamkovoy 2009-12-08 05:46:37 UTC
Created attachment 92268 [details]
NBM with fix for NB 6.8
Comment 19 David Konecny 2009-12-08 11:39:55 UTC
emiddio, please file complation badges problem you described as a new issue. It is not related to EJBs node. Thx.
Comment 20 emiddio 2009-12-08 12:19:04 UTC
installed org-netbeans-modules-j2ee-api-ejbmodule.nbm, made avail in patch from bug id Bug 178176

apparantly does not work in 68rc2
------------------------------------
exception reporter got an exception with i reported with the above text in
the description.
Comment 21 emiddio 2009-12-08 12:22:14 UTC

i see i can provide more info;

Upload of NetBeans Error Report Complete
Your report has been classified as a duplicate of report #162663. It has now been added to the database with id #316354.
This bug was not filed in Bugzilla yet. It will be processed and if it meets certain criteria it will be transferred to NetBeans' Bugzilla bug tracking system automatically.
Your previous reports
Thanks again for your help.  The NetBeans development team!
Comment 22 David Konecny 2009-12-08 13:01:13 UTC
*** Bug 178319 has been marked as a duplicate of this bug. ***
Comment 23 David Konecny 2009-12-08 13:02:22 UTC
Andrey, did you test your fix and nbm? QA, could you retest as well please? Thanks.
Comment 24 emiddio 2009-12-08 13:19:51 UTC
tried to test with nb20091207 daily

would not let me install -- said already installed.

deactivated what appeared to be the module; could not uninstall
after deactivating;

so could not replace or make use of patch in nb20091207

20091207 build also has same problem issue
Comment 25 David Konecny 2009-12-08 14:23:13 UTC
NBM usage is little bit unfortunate - unzip the nbm file (it is regular jar format) and just use /netbeans/modules/org-netbeans-modules-j2ee-api-ejbmodule.jar jar to replace this one: <nb-installation>/enterprise6/modules/org-netbeans-modules-j2ee-api-ejbmodule.jar (as usual, create backup of original file first). That should do the trick.
Comment 26 pgebauer 2010-01-14 02:39:23 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/54260fc58f21


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo