Bug 178091 - Display in title bar path for the edited file
Display in title bar path for the edited file
Status: RESOLVED DUPLICATE of bug 159722
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P2 with 14 votes (vote)
: TBD
Assigned To: issues@platform
issues@platform
:
: 176129 (view as bug list)
Depends on:
Blocks: 178090
  Show dependency treegraph
 
Reported: 2009-12-03 09:31 UTC by Petr Pisl
Modified: 2011-03-22 07:07 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2009-12-03 09:31:20 UTC
This issue can help to solve the problem mentioned in issue #178090 and this issue is the main motivation for this enhancement. 

Almost every editor (including other ides) display the path to the edited file in the title bar. It would be great (but not necessary) if the path length could be configurable. It means how many levels up to the file should be displayed.
Comment 1 tprochazka 2009-12-06 05:09:20 UTC
I totally agree. I have filled relevant issue #155833

For Java project can be show full classpath and for php project file path relative to project root.
Comment 2 Jesse Glick 2010-01-14 08:20:33 UTC
*** Bug 176129 has been marked as a duplicate of this bug. ***
Comment 3 rvdavid 2011-01-21 03:37:02 UTC
Any news on this? I work with a tonne of classes with the same names in different namespaces (directories - I use PHP) and I continually have to go to my auto hidden, docked project window to see where I'm at.
Comment 4 Fishdrowned 2011-03-22 06:55:10 UTC
I don't think this is a minor issue, please pay attention to this.

Once you opened several files (especially some of them have the same file name), you would be eager to know which file you are editing.

Hovering your mouse on the tab and waiting for the path shown, instead of taking a glance at the title bar is a bad idea, and this also gives you a negative impact.
Comment 5 Fishdrowned 2011-03-22 07:07:00 UTC

*** This bug has been marked as a duplicate of bug 159722 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo