Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178023 - second run on a sip app produces lame error
second run on a sip app produces lame error
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 9
6.x
PC Solaris
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-02 14:23 UTC by Vince Kraemer
Modified: 2010-01-25 06:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2009-12-02 14:23:32 UTC
take 6.8
add the sip application development plugins
register sailfin v2
create a converged servlet app that targets your sailfin build
'Run' the app.
   it deploys and all that correctly.

make a whitespace change in a dot-java file.

'Run' the app.
   see the lame error message in the ant output.  the inplace deployment failed.
Comment 1 Vince Kraemer 2009-12-02 14:26:03 UTC
root cause:

in SF v1, a converged servlet app was treated like ModuleType.WAR, but in SF v2, the ModuleType is a special object... so tests for ModuleType.WAR are suspect in a SF v2 deployment environment... if the project is a converged servlet app.
Comment 2 Vince Kraemer 2009-12-04 14:28:19 UTC
http://hg.netbeans.org/web-main/rev/5032c73a3b08
Comment 3 Quality Engineering 2009-12-05 14:36:28 UTC
Integrated into 'main-golden', will be available in build *200912051400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5032c73a3b08
User: Vince Kraemer <vkraemer@netbeans.org>
Log: #178023: lame error message on second run of sip app
Comment 4 pgebauer 2010-01-20 04:07:24 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/3849093b44a8


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo