Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 177999 - Local History > Revert to... did not work
Local History > Revert to... did not work
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Localhistory
6.x
PC Windows Vista
: P2 (vote)
: 6.x
Assigned To: Ondrej Vrabec
issues@versioncontrol
68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-02 08:33 UTC by bdschubert
Modified: 2010-01-18 09:27 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bdschubert 2009-12-02 08:33:05 UTC
Reverting to a local history revision via the Team > Local History > Revert to... menu item and subsequent screen did not work. There was no change in the file contents.  However, using the Show Local History > right mouse click > Revert to... did work.

 I was reverting to a previous Layer.xml file.

NetBeans 6.8 RC1
Comment 1 Ondrej Vrabec 2009-12-02 09:26:32 UTC
fix: http://hg.netbeans.org/cdev/rev/a48de4117e53
Comment 2 Ondrej Vrabec 2009-12-02 09:34:41 UTC
caused by changes in the outline view - http://hg.netbeans.org/main-golden/rev/4b6b9ccd18a5 (fix for bug 170863).
Outline view now clears the selection when a dialog is being disposed.

Unfortunately it is too late to have this fix in 6.8, but there's a simple workaround (Show local history and Revert from there). But i think this could be integrated into some upcoming patch.
Comment 3 Marian Mirilovic 2009-12-02 09:39:50 UTC
OK Ondro, thanks for pointing this out - agreed with Patch 1 candidate.

Pavel, could you please verify this issue once we are done with Nb 6.8 ?
Comment 4 Quality Engineering 2009-12-05 14:34:32 UTC
Integrated into 'main-golden', will be available in build *200912051400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a48de4117e53
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #177999 - Local History > Revert to... did not work
Comment 5 pribyl 2009-12-08 03:02:48 UTC
Product Version: NetBeans IDE Dev (Build 200912080200)
Java: 1.6.0_17; Java HotSpot(TM) Client VM 14.3-b01
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

Verified - works fine now.
Comment 6 pgebauer 2009-12-16 06:46:13 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/126d6ea3fc51
Comment 7 pribyl 2009-12-18 02:36:18 UTC
According to latest instructions for patch nomination I am changing status whiteboard to 68patch-candidate
Comment 8 Marian Mirilovic 2009-12-18 03:19:16 UTC
Pavel, it looks like this issue was already fixed into NB 6.8 Patch 1
Comment 9 pribyl 2009-12-18 03:41:07 UTC
I see, sorry. I overlooked the last comment by Petr G. :(
Comment 10 Jaromir Uhrik 2010-01-18 09:05:11 UTC
Verified in the build which contains the patch:
Product Version: NetBeans IDE 6.8 (Build 201001171801)
Java: 1.6.0_17; Java HotSpot(TM) 64-Bit Server VM 14.3-b01-101
System: Mac OS X version 10.5.8 running on x86_64; MacRoman; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo