Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 177841 - Do not ask for server plugin when server is not installed
Do not ask for server plugin when server is not installed
Status: RESOLVED DUPLICATE of bug 148177
Product: serverplugins
Classification: Unclassified
Component: Code
6.x
PC All
: P2 (vote)
: TBD
Assigned To: Petr Hejl
issues@serverplugins
http://wiki.netbeans.org/FitnessViaWh...
perf-whitelist
: PERFORMANCE, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-30 05:34 UTC by Pavel Flaska
Modified: 2010-02-10 07:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Flaska 2009-11-30 05:34:45 UTC
Whitelist test reported many server plugin classes loaded during classpath resolution even when common j2se project. That is not needed, it should be enough to load only registered servers I think.
Comment 1 Pavel Flaska 2009-11-30 05:55:45 UTC
After fixing, please hg backout 955ad075c62f
http://hg.netbeans.org/ergonomics/rev/955ad075c62f

and verify with whitelist test:
http://wiki.netbeans.org/FitnessViaWhiteAndBlackList
Comment 2 Quality Engineering 2009-12-02 03:00:18 UTC
Integrated into 'main-golden', will be available in build *200912020200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e47694c74f5e
User: Pavel Flaska <pflaska@netbeans.org>
Log: #177841: Forgotten plugin classes.
Comment 3 Petr Jiricka 2010-02-02 05:23:35 UTC
Isn't this a duplicate of bug 148177?
Comment 4 Petr Hejl 2010-02-10 07:44:34 UTC

*** This bug has been marked as a duplicate of bug 148177 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo