Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 177763 - NullPointerException at org.netbeans.modules.java.editor.overridden.ComputeOverriders.findReverseSourceRoots
NullPointerException at org.netbeans.modules.java.editor.overridden.ComputeOv...
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
EXCEPTIONS_REPORT 68patch2-verified
:
: 169731 177785 177857 177862 178919 180382 181016 181110 182746 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-27 09:54 UTC by doctorlux
Modified: 2010-08-17 09:56 UTC (History)
28 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.38 KB, text/plain)
2009-11-27 09:54 UTC, doctorlux
Details
stacktrace (1.38 KB, text/plain)
2009-11-30 08:26 UTC, Chiana
Details
stacktrace (1.38 KB, text/plain)
2009-11-30 08:27 UTC, Chiana
Details
stacktrace (1.38 KB, text/plain)
2009-11-30 10:04 UTC, alied
Details
stacktrace (1.38 KB, text/plain)
2009-11-30 10:19 UTC, misterm
Details
stacktrace (1.38 KB, text/plain)
2009-11-30 10:23 UTC, misterm
Details
stacktrace (1.31 KB, text/plain)
2009-12-04 06:02 UTC, Ivan Sidorkin
Details
stacktrace (1.31 KB, text/plain)
2009-12-04 06:03 UTC, Ivan Sidorkin
Details
stacktrace (1.31 KB, text/plain)
2009-12-04 06:04 UTC, Ivan Sidorkin
Details
stacktrace (1.31 KB, text/plain)
2009-12-04 06:05 UTC, Ivan Sidorkin
Details
stacktrace (2.35 KB, text/plain)
2009-12-08 06:48 UTC, Vladimir Voskresensky
Details
stacktrace (2.35 KB, text/plain)
2009-12-08 14:10 UTC, dheffelfinger
Details
stacktrace (2.21 KB, text/plain)
2009-12-09 08:33 UTC, dheffelfinger
Details
stacktrace (1.31 KB, text/plain)
2009-12-09 11:16 UTC, Jesse Glick
Details
stacktrace (1.80 KB, text/plain)
2010-01-28 03:31 UTC, Alexandr Scherbatiy
Details
stacktrace (2.35 KB, text/plain)
2010-02-09 23:28 UTC, michbarsinai
Details
stacktrace (1.45 KB, text/plain)
2010-02-12 07:52 UTC, stefan79
Details
stacktrace (2.21 KB, text/plain)
2010-02-12 07:53 UTC, stefan79
Details
stacktrace (1.45 KB, text/plain)
2010-02-12 09:05 UTC, stefan79
Details
stacktrace (1.45 KB, text/plain)
2010-02-12 21:31 UTC, adam_myatt
Details
stacktrace (2.35 KB, text/plain)
2010-02-24 07:44 UTC, Michel Graciano
Details
stacktrace (2.35 KB, text/plain)
2010-02-24 07:57 UTC, Michel Graciano
Details
stacktrace (2.21 KB, text/plain)
2010-02-26 05:11 UTC, mkroll
Details
stacktrace (1.45 KB, text/plain)
2010-03-02 05:19 UTC, J Bachorik
Details
stacktrace (8.41 KB, text/plain)
2010-03-02 09:07 UTC, jpleed3
Details
stacktrace (2.35 KB, text/plain)
2010-03-03 10:15 UTC, neilg
Details
stacktrace (2.35 KB, text/plain)
2010-03-03 10:16 UTC, neilg
Details
stacktrace (2.35 KB, text/plain)
2010-03-03 10:17 UTC, neilg
Details
stacktrace (2.21 KB, text/plain)
2010-03-16 14:55 UTC, Karol Harezlak
Details
stacktrace (1.80 KB, text/plain)
2010-03-26 11:03 UTC, Alexey Vladykin
Details
stacktrace (2.21 KB, text/plain)
2010-03-26 19:12 UTC, matthies
Details
stacktrace (2.21 KB, text/plain)
2010-03-26 19:14 UTC, matthies
Details

Note You need to log in before you can comment on or make changes to this bug.
Description doctorlux 2009-11-27 09:54:42 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-4387-on-091126)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Linux, 2.6.31-15-generic, i386

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.java.editor.overridden.ComputeOverriders.findReverseSourceRoots(ComputeOverriders.java:112)
        at org.netbeans.modules.java.editor.overridden.ComputeOverriders.reverseSourceRootsInOrder(ComputeOverriders.java:294)
        at org.netbeans.modules.java.editor.overridden.ComputeOverriders.computeUsers(ComputeOverriders.java:352)
        at org.netbeans.modules.java.editor.overridden.ComputeOverriders.processImpl(ComputeOverriders.java:217)
        at org.netbeans.modules.java.editor.overridden.ComputeOverriders.process(ComputeOverriders.java:173)
        at org.netbeans.modules.java.editor.overridden.ComputeAnnotations.computeAnnotations(ComputeAnnotations.java:114)
Comment 1 doctorlux 2009-11-27 09:54:46 UTC
Created attachment 91792 [details]
stacktrace
Comment 2 Chiana 2009-11-30 08:26:00 UTC
Created attachment 91863 [details]
stacktrace
Comment 3 Chiana 2009-11-30 08:27:00 UTC
Created attachment 91864 [details]
stacktrace
Comment 4 alied 2009-11-30 10:04:00 UTC
Created attachment 91877 [details]
stacktrace
Comment 5 misterm 2009-11-30 10:19:02 UTC
Created attachment 91879 [details]
stacktrace
Comment 6 misterm 2009-11-30 10:23:01 UTC
Created attachment 91882 [details]
stacktrace
Comment 7 Exceptions Reporter 2009-11-30 10:23:08 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=162960
Comment 8 Jan Lahoda 2009-12-01 05:12:28 UTC
Seems that map returned from IndexingController.getRootDependencies() contains a null value, which it should not contain, if I understand everything correctly.
Comment 9 Jan Lahoda 2009-12-01 05:13:39 UTC
*** Bug 177785 has been marked as a duplicate of this bug. ***
Comment 10 Jan Lahoda 2009-12-01 05:13:58 UTC
*** Bug 177857 has been marked as a duplicate of this bug. ***
Comment 11 Ivan Sidorkin 2009-12-04 06:02:56 UTC
Created attachment 92104 [details]
stacktrace
Comment 12 Ivan Sidorkin 2009-12-04 06:03:58 UTC
Created attachment 92105 [details]
stacktrace
Comment 13 Ivan Sidorkin 2009-12-04 06:04:56 UTC
Created attachment 92106 [details]
stacktrace
Comment 14 Ivan Sidorkin 2009-12-04 06:05:56 UTC
Created attachment 92107 [details]
stacktrace
Comment 15 Vladimir Voskresensky 2009-12-08 06:48:28 UTC
Created attachment 92275 [details]
stacktrace
Comment 16 dheffelfinger 2009-12-08 14:10:31 UTC
Created attachment 92301 [details]
stacktrace
Comment 17 dheffelfinger 2009-12-09 08:33:33 UTC
Created attachment 92344 [details]
stacktrace

Generating JSF pages from entity classes in a Maven web project.
Comment 18 Jesse Glick 2009-12-09 11:16:35 UTC
Created attachment 92353 [details]
stacktrace
Comment 19 Tomas Zezula 2009-12-11 03:32:07 UTC
According to the code in the ComputeOverriders the Map.Entry.getValue() returns null.
But the value in the RU is set only in single place where it is initialized to final variable having a List.
I've added a check into IndexingController which checks for null values.
Comment 20 Tomas Zezula 2009-12-11 03:46:05 UTC
Integrated logging into jet-main 492eaf9098ca
Comment 21 Tomas Zezula 2009-12-12 03:29:58 UTC
Fixed in jet-main 2901c57213c1
Comment 22 Quality Engineering 2009-12-12 06:41:26 UTC
Integrated into 'main-golden', will be available in build *200912120559* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/492eaf9098ca
User: Tomas Zezula <tzezula@netbeans.org>
Log: #177763:NullPointerException at org.netbeans.modules.java.editor.overridden.ComputeOverriders.findReverseSourceRoots
Comment 23 Quality Engineering 2009-12-12 16:07:57 UTC
Integrated into 'main-golden', will be available in build *200912121550* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2901c57213c1
User: Tomas Zezula <tzezula@netbeans.org>
Log: #177763:NullPointerException at org.netbeans.modules.java.editor.overridden.ComputeOverriders.findReverseSourceRoots
Comment 24 Jan Lahoda 2009-12-21 02:05:49 UTC
*** Bug 178919 has been marked as a duplicate of this bug. ***
Comment 25 Jan Lahoda 2009-12-21 07:28:04 UTC
*** Bug 177862 has been marked as a duplicate of this bug. ***
Comment 26 Alexandr Scherbatiy 2010-01-28 03:31:44 UTC
Created attachment 93624 [details]
stacktrace
Comment 27 Jan Lahoda 2010-02-08 04:39:41 UTC
*** Bug 180382 has been marked as a duplicate of this bug. ***
Comment 28 michbarsinai 2010-02-09 23:28:36 UTC
Created attachment 94025 [details]
stacktrace
Comment 29 stefan79 2010-02-12 07:52:38 UTC
Created attachment 94121 [details]
stacktrace
Comment 30 stefan79 2010-02-12 07:53:40 UTC
Created attachment 94122 [details]
stacktrace
Comment 31 stefan79 2010-02-12 09:05:32 UTC
Created attachment 94126 [details]
stacktrace
Comment 32 adam_myatt 2010-02-12 21:31:46 UTC
Created attachment 94135 [details]
stacktrace
Comment 33 Michel Graciano 2010-02-24 07:44:17 UTC
Created attachment 94478 [details]
stacktrace
Comment 34 Michel Graciano 2010-02-24 07:57:44 UTC
Created attachment 94481 [details]
stacktrace
Comment 35 tboerkel 2010-02-25 03:09:51 UTC
So many duplicates and no backport to 6.8?
Comment 36 Michel Graciano 2010-02-25 05:27:51 UTC
First of all, could anyone verify if it really fix the problem? After that we can mark this for next possible patch.
Comment 37 mkroll 2010-02-26 05:11:58 UTC
Created attachment 94548 [details]
stacktrace
Comment 38 olivierw 2010-03-02 03:35:50 UTC
Any chance this fix can be backported to 6.8?
Comment 39 J Bachorik 2010-03-02 05:19:12 UTC
Created attachment 94677 [details]
stacktrace
Comment 40 jpleed3 2010-03-02 09:07:12 UTC
Created attachment 94696 [details]
stacktrace
Comment 41 neilg 2010-03-03 10:15:39 UTC
Created attachment 94732 [details]
stacktrace
Comment 42 neilg 2010-03-03 10:16:39 UTC
Created attachment 94733 [details]
stacktrace
Comment 43 neilg 2010-03-03 10:17:39 UTC
Created attachment 94734 [details]
stacktrace
Comment 44 Vitezslav Stejskal 2010-03-05 04:53:15 UTC
*** Bug 169731 has been marked as a duplicate of this bug. ***
Comment 45 Jan Lahoda 2010-03-08 00:22:56 UTC
*** Bug 181016 has been marked as a duplicate of this bug. ***
Comment 46 Jan Lahoda 2010-03-08 00:23:15 UTC
*** Bug 181110 has been marked as a duplicate of this bug. ***
Comment 47 rbalada 2010-03-08 06:47:24 UTC
Please verify in trunk so it can be ported to 6.8 patch
Comment 48 Petr Blaha 2010-03-11 01:43:26 UTC
v.
Comment 49 pgebauer 2010-03-15 18:37:54 UTC
The fix has been ported into the release68_fixes branch.
http://hg.netbeans.org/release68_fixes/rev/efc5689a525d
Comment 50 Karol Harezlak 2010-03-16 14:55:52 UTC
Created attachment 95241 [details]
stacktrace
Comment 51 Jesse Glick 2010-03-24 19:11:53 UTC
The NPE from JavaCustomIndexer.findDependent just happened to me in a dev build. Is that the same issue as this one? Or something else? Why is the exception reporter putting it here?
Comment 52 Jan Lahoda 2010-03-24 19:37:27 UTC
(In reply to comment #51)
> The NPE from JavaCustomIndexer.findDependent just happened to me in a dev
> build. Is that the same issue as this one? Or something else? Why is the

Your is different, as far as I can tell - I separated it: bug #182709.

> exception reporter putting it here?

The root cause for this bug (in 6.8) was that a map contained null values, although it is not supposed to contain them. This was causing NPEs at three places, all of them duplicated to this bug. The stacktrace of your NPE was similar to one of the original stacktraces, e.g.:
http://netbeans.org/bugzilla/attachment.cgi?id=95241
and the exception reporter probably was not able to recognize the difference. I peeked at several other stacktraces, and they all seem to belong to the original bug, so hopefully there are not many miscategorized reports.
Comment 53 Alexey Vladykin 2010-03-26 11:03:17 UTC
Created attachment 95925 [details]
stacktrace
Comment 54 matthies 2010-03-26 19:12:27 UTC
Created attachment 96005 [details]
stacktrace
Comment 55 matthies 2010-03-26 19:14:27 UTC
Created attachment 96006 [details]
stacktrace
Comment 56 Jan Lahoda 2010-08-17 09:56:28 UTC
*** Bug 182746 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo