Bug 177737 - Cannot install Scan On Demand module using 6.8 RC1
Cannot install Scan On Demand module using 6.8 RC1
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Code
6.x
PC All
: P2 (vote)
: TBD
Assigned To: rnovak
au-issues
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-27 05:10 UTC by dlipin
Modified: 2009-12-02 01:32 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dlipin 2009-11-27 05:10:11 UTC
Any bundle, any platform, any JDK.
After "Scan On Demand" installation the following warning is shown:

Warning - could not install some modules:
	org.netbeans.modules.scanondemand - The module named org.netbeans.modules.parsing.api was needed and not found.

Seems to be some impl/spec/release version wrong handling by AU or wrong dependency used in scanondemand module.

Pavel, could you please check scanondemand dependencies against 6.8 codebase?
Thanks.
Comment 1 dlipin 2009-11-27 05:21:06 UTC
Please reassign back to me and platform/Autoupdate after you make sure that dependencies are OK. Or fix the dependencies and publish the update on UC. Thanks.
Comment 2 Pavel Flaska 2009-11-27 07:09:34 UTC
Connected to:
http://hg.netbeans.org/jet-main/rev/36427ecf6f17

But fixed for contrib modules too:
http://hg.netbeans.org/main/contrib/rev/893a5f4dfd92

Looks like new module has not been propagated to AU. Locally built NBM works without any problem in 6.8 rc1. We will discuss with Robert why old 1.11.2 module on AU was not updated to new 1.12.2.
Comment 3 Pavel Flaska 2009-11-27 07:31:21 UTC
Robert will upload new version of module to AU.
Comment 4 dlipin 2009-12-01 06:55:01 UTC
Pavel,

I wish to extend AutoUpdate (and write an appropriate test) to catch such issues in future and show a warning before proceeding with the installation. 

Did I get it right, that the issue is that scanondemand module have the dependency "org.netbeans.modules.parsing.api = 2" (which means that release version is 0, impl version is 2), and the parsing api module is in fact "org.netbeans.modules.parsing.api/1" (release version is 1) and such situation is not caught as the error, right?
Comment 5 dlipin 2009-12-01 07:40:31 UTC
PS. the important thing is that impl version if parsing api has not changed though release one has changed.
Comment 6 dlipin 2009-12-01 07:54:53 UTC
Just for the record - I`ve filed Issue 177922 against AU.
Comment 7 rnovak 2009-12-01 10:01:20 UTC
The new version of the module is now available on the UC.
Comment 8 Pavel Flaska 2009-12-02 01:32:25 UTC
Dmitry, I have no idea how dependencies resolution works. I think there was only release version change. Dependencies were updated correctly, but the module was not uploaded, I do not know, how it works. Sorry.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo