Bug 177709 - getMainClasses waits for the scan to be finished
getMainClasses waits for the scan to be finished
Status: RESOLVED DUPLICATE of bug 188700
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@projects
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-27 01:03 UTC by sergey461
Modified: 2010-09-24 11:23 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-27 01:03 UTC, sergey461
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergey461 2009-11-27 01:03:35 UTC
Build: NetBeans IDE 6.8 Beta (Build 200910221137)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.31-15-generic-pae, i386

User Comments:
GUEST: Find Usages

stefan79: Opened a file and searched for a String.

dheffelfinger: Clicked on "Debug"


Maximum slowness yet reported was 26422 ms, average is 9258
Comment 1 sergey461 2009-11-27 01:03:40 UTC
Created attachment 91755 [details]
nps snapshot
Comment 2 David Strupl 2009-12-16 03:16:40 UTC
9 out of 12 slownesses reported here are due to the following facts:

1. getMainClasses is blocked while waiting on the scan to be finished
2. Maven support waits for it while being asked to enablement status of one of its actions.

Milos, please evaluate.
Comment 3 Antonin Nebuzelsky 2010-07-30 15:17:46 UTC
Reassigning to default owner.
Comment 4 Antonin Nebuzelsky 2010-09-24 11:23:52 UTC

*** This bug has been marked as a duplicate of bug 188700 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo