Bug 177458 - AWT thread blocked for 13311 ms.
AWT thread blocked for 13311 ms.
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: JSF
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Alexey Butenko
issues@javaee
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-23 10:14 UTC by radomir_cernoch
Modified: 2010-03-19 22:02 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-23 10:14 UTC, radomir_cernoch
Details
nps snapshot (256.00 KB, application/nps)
2009-11-29 19:31 UTC, Exceptions Reporter
Details
nps snapshot (256.00 KB, application/nps)
2009-12-09 10:22 UTC, Evaldo.Garcia.Paula
Details
nps snapshot (256.00 KB, application/nps)
2009-12-25 04:33 UTC, realmag777
Details

Note You need to log in before you can comment on or make changes to this bug.
Description radomir_cernoch 2009-11-23 10:14:05 UTC
This bug was originally marked as duplicate of bug 172931, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 6.8 Beta (Build 200910212001)
VM: Java HotSpot(TM) Client VM, 14.1-b02, Java(TM) SE Runtime Environment, 1.6.0_15-b03
OS: Linux, 2.6.27.37-0.1-default, i386

User Comments:
radomir_cernoch: Clicking on a bean's method from a JSP editor.


Maximum slowness yet reported was 13311 ms, average is 13311
Comment 1 radomir_cernoch 2009-11-23 10:14:10 UTC
Created attachment 91550 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-11-29 19:31:22 UTC
Build: NetBeans IDE 6.8 Beta (Build 200910212001)
VM: Java HotSpot(TM) Client VM, 16.0-b03, Java(TM) SE Runtime Environment, 1.7.0-ea-b59
OS: Windows XP, 5.1, x86

User Comments: 

Maximum slowness yet reported was 192878 ms, average is 53704
Comment 3 Exceptions Reporter 2009-11-29 19:31:30 UTC
Created attachment 91844 [details]
nps snapshot
Comment 4 Evaldo.Garcia.Paula 2009-12-09 10:22:37 UTC
Created attachment 92349 [details]
nps snapshot
Comment 5 realmag777 2009-12-25 04:33:22 UTC
Created attachment 92914 [details]
nps snapshot
Comment 6 Petr Jiricka 2010-03-01 08:09:06 UTC
Could this be related to bug 176818?
Comment 7 Alexey Butenko 2010-03-18 09:30:09 UTC
According to first snapshot it is related to JSF editor.
But I don't understand how further snapshots related to the first.

Marek, could you take a look?
Comment 8 Marek Fukala 2010-03-19 22:02:50 UTC
The first problem has been already fixed - the JsfHyperlinkProvide.isHyperlinkPoint() doesn't trigger the EL parsing which involves the jsf metadata model access and hence java parsing.

The rest of the snapshot seems to be wrongly assigned to this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo