Bug 177387 - Pauses involving MavenFileOwnerQueryImpl
Pauses involving MavenFileOwnerQueryImpl
Status: RESOLVED DUPLICATE of bug 186024
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Antonin Nebuzelsky
issues@projects
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-22 18:36 UTC by geoffw
Modified: 2010-08-18 18:38 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-22 18:36 UTC, geoffw
Details
nps snapshot (256.00 KB, application/nps)
2009-12-01 03:42 UTC, Petr Dvorak
Details
nps snapshot (256.00 KB, application/nps)
2010-01-08 22:11 UTC, Exceptions Reporter
Details
nps snapshot (256.00 KB, application/nps)
2010-03-01 00:31 UTC, unr303
Details

Note You need to log in before you can comment on or make changes to this bug.
Description geoffw 2009-11-22 18:36:51 UTC
This bug was originally marked as duplicate of bug 171690, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build nbms-and-javadoc-4313-on-091116)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Linux, 2.6.31-12-generic, amd64

User Comments:
geoffw: open maven project for first time


Maximum slowness yet reported was 18368 ms, average is 18368
Comment 1 geoffw 2009-11-22 18:36:56 UTC
Created attachment 91492 [details]
nps snapshot
Comment 2 Milos Kleint 2009-11-23 06:48:54 UTC
the closing operation is waiting at many other tasks being performed in other threads (MavenFileOwnerQuery, OpenProjects, GlobalClassPath)

so the action should not execute in AWT thread I believe, reassigning to project/ui
Comment 3 Petr Dvorak 2009-12-01 03:42:22 UTC
Created attachment 91911 [details]
nps snapshot
Comment 4 Exceptions Reporter 2010-01-08 22:11:14 UTC
Created attachment 93147 [details]
nps snapshot

trying to open, and then gave up, and tried to close a large maven project. in general netbeans can be painfully slow - still the best IDE though!
Comment 5 unr303 2010-03-01 00:31:24 UTC
Created attachment 94614 [details]
nps snapshot

Closing a lot of maven projects
Comment 6 Jesse Glick 2010-08-18 18:38:43 UTC
Most issues should be resolved by a simpler FileOwnerQuery. At least one snapshot seems to be unrelated - java.source.classpath.CacheClassPath.propertyChange doing heavy work in a listener callback - but is probably filed separately anyway.

BTW I see nothing from NB 6.9.

*** This bug has been marked as a duplicate of bug 186024 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo