Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 177081 - Source Code Navigator Enhancement
Source Code Navigator Enhancement
Status: RESOLVED DUPLICATE of bug 55841
Product: java
Classification: Unclassified
Component: Navigation
6.x
Macintosh Mac OS X
: P3 (vote)
: TBD
Assigned To: Tomas Zezula
issues@java
:
Depends on: 183531
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-18 06:15 UTC by kakacek
Modified: 2012-12-24 19:41 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Screenshot Of the Current Navigator (147.31 KB, image/png)
2009-11-18 06:15 UTC, kakacek
Details
Context menu of the red project (106.50 KB, image/png)
2012-11-20 13:19 UTC, kakacek
Details
The entire red project but no library sourecs (will not compile) (357.39 KB, application/zip)
2012-11-20 13:19 UTC, kakacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kakacek 2009-11-18 06:15:13 UTC
Created attachment 91247 [details]
Screenshot Of the Current Navigator

The source code navigator (see please an attached image) supports searching. When there is a lot of items in the navigator pane and I do not know the exact name of the identifier I am looking for, the searching is useless for me.

I suggest the following improvement: Replace the searching with the incremental filtering.

1. When I type for example 'a', the navigator items NOT containing the character 'a' (case sensitivity is useless for me in this case) get hidden.
2. When I type 'd' (so the filter is now "ad"), the navigator only contains items containing the "ad" text.
3. When I type another 'd', the navgator only contains items containing the "add" text.
4. And so forth.
5. Of course, the navigation arrows keep working.

This would greatly simplyfy the navigatiopn for me.

Any chance to get this functionality? When?
Comment 1 David Simonek 2009-11-18 09:09:42 UTC
Passing to java navigation...
Comment 2 Tomas Zezula 2009-11-18 09:30:01 UTC
Sounds good.
Adding UI engineer to review.
Comment 3 Vitezslav Stejskal 2009-11-20 02:46:47 UTC
This indeed would be a great enhancement. But I don't understand why this should be solved only for java. It's a generic feature in the generic Navigator component, which should work for all types of navigators (or even in all tree view components). Or am I smoking something funny?
Comment 4 Tomas Zezula 2009-11-20 02:51:52 UTC
The problem is that platform navigator infrastructure is rather "dummy" and SPI (java) provides panel to it.
The platform infrastructure has no control on panel content.
Comment 5 kakacek 2009-11-20 02:55:49 UTC
I did mean this as generic feature. I was only not completely sure where to put my request to. I did probably wrong. Sorry.
Comment 6 Tomas Zezula 2009-11-20 03:21:40 UTC
No. The issue was placed in correct module and thanks for it.
The discussion about generic vs java is rather an implementation problem.
Comment 7 Vitezslav Stejskal 2009-11-20 04:53:04 UTC
(In reply to comment #4)
> The problem is that platform navigator infrastructure is rather "dummy" and SPI
> (java) provides panel to it.
> The platform infrastructure has no control on panel content.

Ok, but the current search feature is not implemented in java or is it? I always thought it's in BeanTreeView or somewhere there and works with generic nodes. But I am probably wrong.
Comment 8 Tomas Zezula 2009-11-20 05:08:33 UTC
>Ok, but the current search feature is not implemented in java or is it? I
>always thought it's in BeanTreeView or somewhere there and works with generic
>nodes. But I am probably wrong.
No, you are right Vito.  The search comes from the BeanTreeView. But I am not sure if we will be able to change it there as it will affect the whole IDE. But maybe there can be per instance switch affecting just given BTW instance (the navigator).
Comment 9 Ondrej Langr 2009-11-24 02:56:01 UTC
> Adding UI engineer to review.

Sorry for the delay. Yes, this would be a great enhancement, indeed.

IMHO, this would be desirable behavior for all trees in the IDE.
Comment 10 Vitezslav Stejskal 2009-11-30 02:13:08 UTC
We need a support for this in BeanTreeView.
Comment 11 Jaroslav Tulach 2010-04-02 18:41:58 UTC
If you need something from the platform (like a pluggable handling of search), report that in another issue, please. This one is clearly won'tfix for platform.
Comment 12 Tomas Zezula 2010-04-06 08:09:56 UTC
OK Jardo I will create a new one.
Comment 13 kakacek 2012-11-20 13:19:16 UTC
Created attachment 128128 [details]
Context menu of the red project
Comment 14 kakacek 2012-11-20 13:19:46 UTC
Created attachment 128129 [details]
The entire red project but no library sourecs (will not compile)
Comment 15 markiewb 2012-12-24 19:41:00 UTC

*** This bug has been marked as a duplicate of bug 55841 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo