Bug 176960 - In RESTful WS from Database wizard, unfixable No Persistence Unit error msg
In RESTful WS from Database wizard, unfixable No Persistence Unit error msg
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: REST
6.x
PC Windows Vista
: P2 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
68patch-candidate
: UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 17:07 UTC by Jeffrey Rubinoff
Modified: 2010-05-20 12:24 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot of error blocking wizard progress (28.77 KB, image/png)
2009-11-16 17:07 UTC, Jeffrey Rubinoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey Rubinoff 2009-11-16 17:07:04 UTC
Created attachment 91142 [details]
Screenshot of error blocking wizard progress

If you are creating a RESTful WS from Database, in the Database Tables page, I got an error message saying that "Current Project has no Persistence Unit. Please use New Persistence Unit wizard to create one."
However, I got this message right after I added tables to the entity classes. I cannot use the New Persistence Unit wizard because that wizard is not available until I get to the Entity Classes page in the RESTful WS from Database wizard. However, the error blocks me from continuing to the next page! 
Can work around it by launching New Persistence Unit wizard from New > Persistence. But if this is on purpose, could the RESTful WS from Database wizard at least say to cancel the wizard and launch the New Persistence Unit wizard from New > Persistence? If this is on purpose and not a bug, it certainly looks like a bug to anyone used to the Entity Classes from Database wizard.
Comment 1 Milan Kuchtiak 2009-11-18 01:54:17 UTC
Yes, RESTful WS from Database requires existence of persistence unit.
The wizard should allow to create it.

You're right the table selection has no sense when persistence unit is missing.
I'd qualify that as bug too.
Comment 2 Milan Kuchtiak 2009-11-20 01:22:57 UTC
It's too late to fix this to 6.8.
Comment 3 Martin Schovanek 2010-01-19 05:30:02 UTC
Please consider fix it for 68-patch1. Ugly bug, moreover mentioned at: http://netbeans.org/kb/docs/websvc/rest.html
Comment 4 Lukas Jungmann 2010-01-19 08:06:10 UTC
There is a create PU button in the wizard but user doesn't see it anymore because of a fix for issue #150378.

The fix for this would mean reverting http://hg.netbeans.org/main-silver/rev/1598cba016d8 and properly fixing the case mentioned in issue #150378 - which is regular P3, so maybe this wouldn't be needed... Opinions?
Comment 5 Martin Schovanek 2010-01-19 09:07:54 UTC
A correct fix for the issue #150378 sounds like good solution ;) Milane can you please evaluate?
Comment 6 Milan Kuchtiak 2010-01-20 01:58:44 UTC
OK, I'll try to fix that.
Comment 8 Jaroslav Pospisil 2010-05-20 12:24:51 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo