Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 176958 - AssertionError at org.netbeans.modules.junit.DefaultPlugin.createTestClass
AssertionError at org.netbeans.modules.junit.DefaultPlugin.createTestClass
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: JUnit
6.x
All All
: P2 (vote)
: 7.1
Assigned To: Theofanis Oikonomou
junit-issues@java
EXCEPTIONS_REPORT
:
: 174262 193673 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 16:55 UTC by Michal Mocnak
Modified: 2011-12-07 15:13 UTC (History)
15 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.38 KB, text/plain)
2009-11-16 16:55 UTC, Michal Mocnak
Details
stacktrace (7.17 KB, text/plain)
2010-11-20 14:42 UTC, areeda
Details
stacktrace (7.20 KB, text/plain)
2010-11-27 21:25 UTC, michal.owsiak
Details
stacktrace (7.16 KB, text/plain)
2010-12-08 16:12 UTC, Egor Ushakov
Details
stacktrace (7.14 KB, text/plain)
2010-12-21 09:15 UTC, esmithbss
Details
stacktrace (8.76 KB, text/plain)
2011-06-03 02:26 UTC, alied
Details
stacktrace (8.62 KB, text/plain)
2011-06-22 07:49 UTC, muellermi
Details
stacktrace (5.99 KB, text/plain)
2011-11-01 15:07 UTC, dbell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Mocnak 2009-11-16 16:55:34 UTC
Build: NetBeans IDE Dev (Build 200911160201)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.1-b02-90, Java(TM) SE Runtime Environment, 1.6.0_15-b03-219
OS: Mac OS X, 10.6.2, x86_64

User Comments:
GUEST: Tried to create a new JUnit Test Suite



Stacktrace: 
java.lang.AssertionError
        at org.netbeans.modules.junit.DefaultPlugin.createTestClass(DefaultPlugin.java:2025)
        at org.netbeans.modules.junit.DefaultPlugin.createSuiteTest(DefaultPlugin.java:1890)
        at org.netbeans.modules.junit.DefaultPlugin.createSuiteTest(DefaultPlugin.java:2001)
        at org.netbeans.modules.junit.wizards.TestSuiteWizardIterator.instantiate(TestSuiteWizardIterator.java:303)
        at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:588)
        at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:409)
Comment 1 Michal Mocnak 2009-11-16 16:55:36 UTC
Created attachment 91141 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-11-24 21:51:06 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=149351
Comment 3 Victor Vasilyev 2010-03-26 09:40:41 UTC
To find bug location the debug output is added to the assert statement
http://hg.netbeans.org/main/rev/e58d13bcf53c
Comment 4 Victor Vasilyev 2010-03-26 17:49:59 UTC
*** Bug 174262 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Stupka 2010-09-24 12:52:15 UTC
still happens - see last report from build 100924
Comment 6 Victor Vasilyev 2010-09-24 13:07:29 UTC
Please, give me a link to the report.
Comment 8 Victor Vasilyev 2010-09-24 13:31:11 UTC
Thanks. I'll investigate it.
Comment 9 areeda 2010-11-20 14:42:36 UTC
Created attachment 103134 [details]
stacktrace

Running JUnit TS 68

In Test and Testsuite Files on the last step.

I also had this last weekend on a nightly build.
Comment 10 quanghung.b 2010-11-23 23:15:24 UTC
Like Joe (areeda), I am running the TS 68 JUnit too under NB 7 Beta 1.
And  I got the same exception when I try to create a new test suite with more than 1 folder in "Test Package Folders" 
(and the exception error message seems to report the right cause : "More than one root in the ClassPath=")
Comment 11 michal.owsiak 2010-11-27 21:25:25 UTC
Created attachment 103408 [details]
stacktrace

I was creating Test Suite for test project - JUnitSampleProject
Comment 12 michal.owsiak 2010-11-29 17:56:03 UTC
I was creating JUnit Test for JUnit Test Project at Mac OS X

java.lang.AssertionError: Please, re-open Bug 176958 with the following info:
More than one root in the ClassPath=/Users/michalo/NetBeansProjects/JUnitSampleProject/test2:/Users/michalo/NetBeansProjects/JUnitSampleProject/test
	at org.netbeans.modules.junit.DefaultPlugin.createTestClass(DefaultPlugin.java:2029)
	at org.netbeans.modules.junit.DefaultPlugin.createSuiteTest(DefaultPlugin.java:1893)
	at org.netbeans.modules.junit.DefaultPlugin.createSuiteTest(DefaultPlugin.java:2004)
	at org.netbeans.modules.junit.wizards.TestSuiteWizardIterator.instantiate(TestSuiteWizardIterator.java:313)
	at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:591)
	at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:412)
	at org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:251)
	at org.openide.loaders.TemplateWizardIteratorWrapper.instantiate(TemplateWizardIteratorWrapper.java:164)
	at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1551)
	at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1505)
	at org.openide.WizardDescriptor.access$1700(WizardDescriptor.java:137)
	at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:2076)
	at org.openide.WizardDescriptor$Listener$2.run(WizardDescriptor.java:2125)
	at org.openide.WizardDescriptor.lazyValidate(WizardDescriptor.java:1480)
	at org.openide.WizardDescriptor.access$1300(WizardDescriptor.java:137)
	at org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:2132)
Caused: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:459)
Caused: java.lang.reflect.UndeclaredThrowableException
	at $Proxy32.actionPerformed(Unknown Source)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.Component.processMouseEvent(Component.java:6352)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6117)
	at java.awt.Container.processEvent(Container.java:2085)
	at java.awt.Component.dispatchEventImpl(Component.java:4714)
	at java.awt.Container.dispatchEventImpl(Container.java:2143)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4621)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4282)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4212)
	at java.awt.Container.dispatchEventImpl(Container.java:2129)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:635)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:138)
[catch] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:205)
	at java.awt.Dialog$1.run(Dialog.java:1046)
	at java.awt.Dialog$3.run(Dialog.java:1098)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1096)
	at org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:1006)
	at org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:1040)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:1028)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:121)
	at org.openide.util.Mutex.doEventAccess(Mutex.java:1361)
	at org.openide.util.Mutex.readAccess(Mutex.java:271)
	at org.netbeans.core.windows.services.NbPresenter.show(NbPresenter.java:1013)
	at java.awt.Component.show(Component.java:1563)
	at java.awt.Component.setVisible(Component.java:1515)
	at java.awt.Window.setVisible(Window.java:842)
	at java.awt.Dialog.setVisible(Dialog.java:986)
	at org.openide.loaders.TemplateWizard.instantiateImpl(TemplateWizard.java:498)
	at org.openide.loaders.TemplateWizard.instantiate(TemplateWizard.java:365)
	at org.netbeans.modules.project.ui.actions.NewFile.doPerform(NewFile.java:157)
	at org.netbeans.modules.project.ui.actions.NewFile.access$200(NewFile.java:83)
	at org.netbeans.modules.project.ui.actions.NewFile$PopupListener.actionPerformed(NewFile.java:336)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:389)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1223)
	at com.apple.laf.AquaMenuItemUI.doClick(AquaMenuItemUI.java:137)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1264)
	at java.awt.Component.processMouseEvent(Component.java:6352)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6117)
	at java.awt.Container.processEvent(Container.java:2085)
	at java.awt.Component.dispatchEventImpl(Component.java:4714)
	at java.awt.Container.dispatchEventImpl(Container.java:2143)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4621)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4282)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4212)
	at java.awt.Container.dispatchEventImpl(Container.java:2129)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:635)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:138)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 13 Egor Ushakov 2010-12-08 16:10:35 UTC
same for me, stacktrace is the same
Comment 14 Egor Ushakov 2010-12-08 16:12:48 UTC
Created attachment 103746 [details]
stacktrace
Comment 15 Jan Lahoda 2010-12-21 07:26:38 UTC
*** Bug 193673 has been marked as a duplicate of this bug. ***
Comment 16 esmithbss 2010-12-21 09:15:18 UTC
Created attachment 104339 [details]
stacktrace

Attempting to create a new JUnit Test Suite.
Comment 17 alied 2011-06-03 02:26:55 UTC
Created attachment 108685 [details]
stacktrace

creating a test suite for a package
Comment 18 muellermi 2011-06-22 07:49:16 UTC
Created attachment 109042 [details]
stacktrace

create test suite by wizard
Comment 19 dbell 2011-11-01 15:00:06 UTC
This bug has >20 exception reports so increasing priority to P2 based on Bug Priority Guidelines [1].
[1] http://wiki.netbeans.org/BugPriorityGuidelines
Comment 20 dbell 2011-11-01 15:07:54 UTC
Created attachment 112684 [details]
stacktrace

New > JUnit > test suite
Comment 21 Theofanis Oikonomou 2011-11-10 14:15:09 UTC
Fixed

http://hg.netbeans.org/core-main/rev/1f53817771e7
Comment 22 Quality Engineering 2011-11-11 15:38:46 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/1f53817771e7
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Issue #176958 - AssertionError at org.netbeans.modules.junit.DefaultPlugin.createTestClass
Comment 23 Jiri Prox 2011-12-07 15:13:12 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo