Bug 176865 - [69cat] ~5s wasted in NavigatorTC.setPanels
[69cat] ~5s wasted in NavigatorTC.setPanels
Status: RESOLVED DUPLICATE of bug 172822
Product: platform
Classification: Unclassified
Component: Navigator
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 176969 177164 177901 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-15 15:18 UTC by tveimo
Modified: 2010-03-29 16:30 UTC (History)
16 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-15 15:18 UTC, tveimo
Details
nps snapshot (256.00 KB, application/nps)
2009-11-15 15:19 UTC, tveimo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tveimo 2009-11-15 15:18:47 UTC
Build: NetBeans IDE 6.8 Beta (Build 200910212001)
VM: Java HotSpot(TM) Client VM, 14.1-b02-90, Java(TM) SE Runtime Environment, 1.6.0_15-b03-219
OS: Mac OS X, 10.6.2, i386

User Comments:
GUEST: opening project

GUEST: opening java file

GUEST: I keep getting this error when I start up Netbeans 6.8, and it's been hanging a lot too.

nlloyd@gmail.com: Opening a JUnit Test Suite java file in a ~3000 class file maven project while running a maven clean on the same project in the background.


Maximum slowness yet reported was 8970 ms, average is 5208
Comment 1 tveimo 2009-11-15 15:18:52 UTC
Created attachment 91058 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-11-15 15:18:58 UTC
This issue already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161618
Comment 3 tveimo 2009-11-15 15:19:55 UTC
Created attachment 91059 [details]
nps snapshot
Comment 4 Exceptions Reporter 2009-11-15 15:20:01 UTC
This issue already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161618
Comment 5 Exceptions Reporter 2009-11-16 02:31:07 UTC
This issue already has 11 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161618
Comment 6 Exceptions Reporter 2009-11-16 06:54:33 UTC
This issue already has 12 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161618
Comment 7 Exceptions Reporter 2009-11-17 01:03:47 UTC
This issue already has 13 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161618
Comment 8 t_h 2009-11-18 07:45:26 UTC
*** Bug 176969 has been marked as a duplicate of this bug. ***
Comment 9 t_h 2009-11-19 02:00:56 UTC
*** Bug 177164 has been marked as a duplicate of this bug. ***
Comment 10 t_h 2009-12-02 03:22:05 UTC
*** Bug 177901 has been marked as a duplicate of this bug. ***
Comment 11 Jaroslav Tulach 2010-02-01 08:45:19 UTC
Looking at
http://statistics.netbeans.org/exceptions/exception.do?id=327928
and
http://statistics.netbeans.org/exceptions/exception.do?id=330456
I assume the problem is that org.netbeans.modules.navigator.NavigatorTC.setPanels() can be expensive. The fix is to compute only the first, visible panel and not all of them.
Comment 12 David Simonek 2010-03-29 16:30:59 UTC
Yes, as discussed in 172822

*** This bug has been marked as a duplicate of bug 172822 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo