Bug 176744 - !!!!! COLLECTOR SAYS !!!! messages in log
!!!!! COLLECTOR SAYS !!!! messages in log
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Profile
6.x
All Solaris
: P2 (vote)
: 6.x
Assigned To: issues@cnd
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-12 20:49 UTC by Thomas Preisler
Modified: 2009-11-13 01:11 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Preisler 2009-11-12 20:49:05 UTC
Profiling on OpenSolaris/C/C++ Sun Studio Standard configurations. Log contains tons of the messages below. We should not release with this kind of loggin on. Why is there a dbx message? I didn't start dbx.

!!!!! COLLECTOR SAYS !!!! : Reading fractal_3
!!!!! COLLECTOR SAYS !!!! : Reading ld.so.1
!!!!! COLLECTOR SAYS !!!! : Reading unbuffer.so
!!!!! COLLECTOR SAYS !!!! : Reading libCstd.so.1
!!!!! COLLECTOR SAYS !!!! : Reading libCrun.so.1
!!!!! COLLECTOR SAYS !!!! : Reading libm.so.2
!!!!! COLLECTOR SAYS !!!! : Reading libc.so.1
!!!!! COLLECTOR SAYS !!!! : Attached to process 2407
!!!!! COLLECTOR SAYS !!!! : stopped in __fast_double_to_decimal at 0xfec94fa6
!!!!! COLLECTOR SAYS !!!! : 0xfec94fa6: __fast_double_to_decimal+0x000e:        popl     %ebx
!!!!! COLLECTOR SAYS !!!! : Current function is Mandelbrot (optimized)
!!!!! COLLECTOR SAYS !!!! :   160 fprintf(fh, "%d %lf %lf\n", max[ii][jj], (float)realBuf[ii][jj], (float)imgBuf[ii][jj]);
!!!!! COLLECTOR SAYS !!!! : Creating experiment database /var/tmp/dlight_thp/experiment_7.er ...
!!!!! COLLECTOR SAYS !!!! : Reading libcollector.so
!!!!! COLLECTOR SAYS !!!! : Reading libdl.so.1
!!!!! COLLECTOR SAYS !!!! : dbx: warning: Experiment name is an absolute path; directory name /var/tmp/dlight_thp ignored.
!!!!! COLLECTOR SAYS !!!! :
!!!!! COLLECTOR SAYS !!!! : execution completed, exit code is 0
!!!!! COLLECTOR SAYS !!!! : Reading fractal_3
!!!!! COLLECTOR SAYS !!!! : Reading ld.so.1
!!!!! COLLECTOR SAYS !!!! : Reading unbuffer.so
!!!!! COLLECTOR SAYS !!!! : Reading libCstd.so.1
!!!!! COLLECTOR SAYS !!!! : Reading libCrun.so.1
!!!!! COLLECTOR SAYS !!!! : Reading libm.so.2
!!!!! COLLECTOR SAYS !!!! : Reading libc.so.1
!!!!! COLLECTOR SAYS !!!! : Attached to process 2530
!!!!! COLLECTOR SAYS !!!! : stopped in __write at 0xfed22745
!!!!! COLLECTOR SAYS !!!! : 0xfed22745: __write+0x0015:        jae __write+0x21        [ 0xfed22751, .+0xc ]
!!!!! COLLECTOR SAYS !!!! : Current function is Mandelbrot (optimized)
!!!!! COLLECTOR SAYS !!!! :   160 fprintf(fh, "%d %lf %lf\n", max[ii][jj], (float)realBuf[ii][jj], (float)imgBuf[ii][jj]);
!!!!! COLLECTOR SAYS !!!! : Creating experiment database /var/tmp/dlight_thp/experiment_8.er ...
!!!!! COLLECTOR SAYS !!!! : Reading libcollector.so
!!!!! COLLECTOR SAYS !!!! : Reading libdl.so.1
!!!!! COLLECTOR SAYS !!!! : dbx: warning: Experiment name is an absolute path; directory name /var/tmp/dlight_thp ignored.
Comment 1 Andrew Krasny 2009-11-12 22:45:27 UTC
Thomas, 

is there is something in your hotspotrc? dbxrc? 
Either the collect you use was changed and now it's default verbose level has changed or you have enabled this verbose level somehow... 

regarding dbx - collect just uses it. so it's normal.
Comment 2 Thomas Preisler 2009-11-12 22:55:34 UTC
> is there is something in your hotspotrc? dbxrc? 
no.

>Either the collect you use was changed and now it's default verbose level has
changed or you have enabled this verbose level somehow... 
I'm using the collector from the SS12.1 collection that can be downloaded from the OpenSolaris repository. As far as I know. I will double check this.....
Comment 3 Thomas Preisler 2009-11-13 00:47:19 UTC
I cannot reproduce this on demand but I have seen it several time over the last couple of days. Something must trigger it. You can close/downgrade if you like.....
Comment 4 Andrew Krasny 2009-11-13 01:11:28 UTC
http://hg.netbeans.org/cnd-main/rev/f42542cff302

enable output if logger has verbose level set to FINEST.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo