Bug 176597 - YAGL in BinaryFS.modifications
YAGL in BinaryFS.modifications
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Module System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@platform
EXCEPTIONS_REPORT perf-profileme
: ERGONOMICS, PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-11 14:48 UTC by Exceptions Reporter
Modified: 2009-11-24 19:09 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-11 14:48 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2009-11-11 14:48:54 UTC
Build: NetBeans IDE 6.8 Beta (Build 200910212001)
VM: OpenJDK 64-Bit Server VM, 14.0-b16, OpenJDK Runtime Environment, 1.6.0_0-b16
OS: Linux, 2.6.30.9-96.fc11.x86_64, amd64

User Comments:
ravindranathakila: Building a project. Maven build says "Additional maven build processing". There is nothing running in the background of this pc and is very fast.

GUEST: just updating

esmithbss: Activating JavaSE and RubyOnRails Capabilities


Maximum slowness yet reported was 6953 ms, average is 3906
Comment 1 Exceptions Reporter 2009-11-11 14:48:59 UTC
Created attachment 90849 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-11-11 14:49:04 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=159397
Comment 3 Stanislav Aubrecht 2009-11-12 03:44:36 UTC
can performance team help me with this one pls?
org.openide.awt.Actions.connect is waiting for Lookup.lookupAll (i guess because new modules are being activated). but i don't know what i can do with this.
Comment 4 Exceptions Reporter 2009-11-20 08:17:04 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=159397
Comment 5 jacorream 2009-11-20 08:19:55 UTC
I was not doing anything special. Browsing JAVA files
Comment 6 Jaroslav Tulach 2009-11-20 14:37:44 UTC
The http://statistics.netbeans.org/exceptions/exception.do?id=304958 shows YAGL on BinaryFS.modifications. At least 2.5s are spend by one thread waiting on another.
Comment 7 Jesse Glick 2009-11-20 18:48:17 UTC
Actions.connect calls Lookup.getDefault().lookupAll(ButtonActionConnector.class). Folder lookup is doing some disk I/O.

In at least two cases, lookup is so busy because features are being turned on, at least judging by the FoD dialog being shown. In another, loading bundles from a ZIP.

Nothing to be improved that I can see.

(What is "YAGL"?)
Comment 8 dlipin 2009-11-21 22:19:02 UTC
> (What is "YAGL"?)
yet another global lock
Comment 9 Jaroslav Tulach 2009-11-22 01:27:15 UTC
The YAGL needs to be eliminated.
Comment 10 Jaroslav Tulach 2009-11-23 05:35:21 UTC
Shall I fix the BinaryFS code or can you handle it, Jesse? Or shall Jirka do it, as it is FS related?
Comment 11 Jesse Glick 2009-11-23 13:33:41 UTC
I think I see what you are suggesting, though I have no idea how to reproduce or confirm the fix: core-main #09ece988d1e5
Comment 12 Jaroslav Tulach 2009-11-24 02:33:57 UTC
You could write URL handler that will block when the code calls:
new URL(urls.get(index))
and then try whether another lastModified() can finish when queried from another thread.
Comment 13 Quality Engineering 2009-11-24 19:09:09 UTC
Integrated into 'main-golden', will be available in build *200911241400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/09ece988d1e5
User: Jesse Glick <jglick@netbeans.org>
Log: #176597: avoid a global lock when checking modification times.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo