Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 176595 - [68cat] ClassCastException: org.apache.xerces.parsers.XIncludeAwareParserConfiguration cannot be cast to org.apache.xerces.xni.parser.XMLParserConfiguration
[68cat] ClassCastException: org.apache.xerces.parsers.XIncludeAwareParserConf...
Status: RESOLVED WORKSFORME
Product: javaee
Classification: Unclassified
Component: JSF Editor
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Marek Fukala
issues@javaee
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-11 13:51 UTC by gholmer
Modified: 2009-11-13 06:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.37 KB, text/plain)
2009-11-11 13:51 UTC, gholmer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gholmer 2009-11-11 13:51:53 UTC
Build: NetBeans IDE Dev (Build 200911091156)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Linux, 2.6.28-16-generic, i386

User Comments:
gholmer: Appeared during a compile with an XHTML file open in the editor.  After this exception appears, all the tags in the XHTML file are marked as errors (red squiggly line), and the error dialog continues to come up about once a second until NetBeans is restarted.



Stacktrace: 
java.lang.ClassCastException: org.apache.xerces.parsers.XIncludeAwareParserConfiguration cannot be cast to org.apache.xerces.xni.parser.XMLParserConfiguration
        at org.apache.xerces.parsers.DOMParser.<init>(DOMParser.java:0)
        at org.apache.xerces.parsers.DOMParser.<init>(DOMParser.java:0)
        at org.apache.xerces.jaxp.DocumentBuilderImpl.<init>(DocumentBuilderImpl.java:0)
        at org.apache.xerces.jaxp.DocumentBuilderFactoryImpl.newDocumentBuilder(DocumentBuilderFactoryImpl.java:0)
        at com.sun.org.apache.xalan.internal.xsltc.trax.SAX2DOM.createDocument(SAX2DOM.java:326)
        at com.sun.org.apache.xalan.internal.xsltc.trax.SAX2DOM.<init>(SAX2DOM.java:85)
Comment 1 gholmer 2009-11-11 13:51:57 UTC
Created attachment 90846 [details]
stacktrace
Comment 2 Marek Fukala 2009-11-13 03:45:51 UTC
I cannot reproduce this issue since there is another one blocking me - Issue #176771. I'll evaluate this one once I manage to fix the second.
Comment 3 Marek Fukala 2009-11-13 05:18:49 UTC
The blocking issue #176771 has been fixed, but I cannot reproduce the issue reported here. 

Is that always reproducible? On what project type? What libraries do you have? Did you somehow fiddled with the project configuration? If you can reproduce, could you please attach the project here or send it directly to me if confidential?

Closing the issue as worksforme, please reopen once you have the answers. 

Thanks.
Comment 4 gholmer 2009-11-13 06:17:39 UTC
I have not seen it again.  I am thinking it may be a side effect of having replaced org-netbeans-modules-web-jsf-editor.jar during testing for 176255 (which I later reverted).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo