Bug 176576 - [69cat][68cat] AWT thread blocked for 5562 ms.
[69cat][68cat] AWT thread blocked for 5562 ms.
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P3 (vote)
: 7.0
Assigned To: dlipin
au-issues
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-11 10:48 UTC by misterm
Modified: 2010-05-28 08:05 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-11 10:48 UTC, misterm
Details
bug176576.patch (1.23 KB, patch)
2010-05-27 14:12 UTC, Victor Vasilyev
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2009-11-11 10:48:50 UTC
Build: NetBeans IDE Dev (Build 091110-2ed0c0f492b5)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_04-b12
OS: Windows XP, 5.1, x86

User Comments:
GUEST: Switching in plugins tab from Updates to Available plugins

GUEST: Just opened the plugins window.

vijaykiran: Opened Tools -> Plugins
Clicked on Reload Catalog
Clicked on Installed Tab

giorgio42: Switching from Updates to Available Plugins tab in Plugin Manager.


Maximum slowness yet reported was 7047 ms, average is 4081
Comment 1 misterm 2009-11-11 10:48:55 UTC
Created attachment 90837 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-11-11 10:49:01 UTC
This issue already has 13 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=156442
Comment 3 Victor Vasilyev 2010-05-27 14:12:02 UTC
Created attachment 99545 [details]
bug176576.patch

The problem is that the method PluginManagerUI.isValidHelpID(String id) is very time consuming, because it initiate opening of all help sets accessible in the NetBeans. Nevertheless, this method is called for purposes of logging only.
Hence, it can be fixed easily via attached patch.

Please, validate the patch, and apply it if all is OK.
Comment 4 Victor Vasilyev 2010-05-27 14:15:07 UTC
Re-assign to an owner of the Auto Update UI module.
Comment 6 Quality Engineering 2010-05-28 08:05:25 UTC
Integrated into 'main-golden', will be available in build *201005280001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/32094373d44e
User: Dmitry Lipin <dlipin@netbeans.org>
Log: Issue #176576 [69cat][68cat] AWT thread blocked for 5562 ms


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo