Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 176506 - [68cat] AWT thread blocked for 3299 ms.
[68cat] AWT thread blocked for 3299 ms.
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Text
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: David Strupl
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on: 180595
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-11 04:36 UTC by aldobrucale
Modified: 2010-03-15 12:52 UTC (History)
52 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-11 04:36 UTC, aldobrucale
Details
nps snapshot (256.00 KB, application/nps)
2009-11-11 22:18 UTC, savarun
Details
nps snapshot (256.00 KB, application/nps)
2009-11-13 08:32 UTC, jfderaismes
Details
nps snapshot (256.00 KB, application/nps)
2009-11-17 11:34 UTC, iceman81
Details
nps snapshot (256.00 KB, application/nps)
2009-11-20 13:22 UTC, jfderaismes
Details
nps snapshot (256.00 KB, application/nps)
2009-11-26 11:01 UTC, Eduardo.m Costa
Details
nps snapshot (256.00 KB, application/nps)
2009-12-01 03:22 UTC, Eduardo.m Costa
Details
nps snapshot (256.00 KB, application/nps)
2009-12-09 02:09 UTC, majiknet
Details
nps snapshot (256.00 KB, application/nps)
2009-12-14 07:17 UTC, cgmarroq
Details
nps snapshot (256.00 KB, application/nps)
2009-12-17 10:42 UTC, cgmarroq
Details
nps snapshot (256.00 KB, application/nps)
2009-12-18 00:50 UTC, sgtgarcia
Details
nps snapshot (256.00 KB, application/nps)
2010-01-06 07:38 UTC, tapehead
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aldobrucale 2009-11-11 04:36:53 UTC
This issue was originally marked as duplicate of issue 171713, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE Dev (Build 200911091156)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Linux, 2.6.31-14-generic, i386

User Comments:
aldobrucale: Starting nb


Maximum slowness yet reported was 3299 ms, average is 3299
Comment 1 aldobrucale 2009-11-11 04:36:59 UTC
Created attachment 90785 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-11-11 13:55:55 UTC
This issue already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161807
Comment 3 savarun 2009-11-11 22:18:13 UTC
Created attachment 90861 [details]
nps snapshot
Comment 4 Exceptions Reporter 2009-11-11 22:18:19 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161807
Comment 5 jfderaismes 2009-11-13 08:32:36 UTC
Created attachment 91012 [details]
nps snapshot
Comment 6 Exceptions Reporter 2009-11-13 21:47:00 UTC
This issue already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161807
Comment 7 mslama 2009-11-16 07:05:32 UTC
Different issues mostly caused by calling EditorCookie.getOpenedPanes or CloneableEditor.getEditorPane. Honzo is anywhere complete example how to use NbDocument.findRecentEditorPane?

One case is from
gototest/src/org/netbeans/modules/gototest/GotoOppositeAction.java
Another case is from
xml.text/src/org/netbeans/modules/xml/text/navigator/NavigatorContent.java
Comment 8 David Strupl 2009-11-16 10:09:42 UTC
I don't think this is a P2 and I agree this will be fixed post 6.8.
Comment 9 iceman81 2009-11-17 11:34:59 UTC
Created attachment 91194 [details]
nps snapshot
Comment 10 Exceptions Reporter 2009-11-19 15:18:47 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=161807
Comment 11 jfderaismes 2009-11-20 13:22:14 UTC
Created attachment 91448 [details]
nps snapshot
Comment 12 Eduardo.m Costa 2009-11-26 11:01:32 UTC
Created attachment 91743 [details]
nps snapshot
Comment 13 Eduardo.m Costa 2009-12-01 03:22:23 UTC
Created attachment 91906 [details]
nps snapshot
Comment 14 majiknet 2009-12-09 02:09:29 UTC
Created attachment 92319 [details]
nps snapshot

Starting up Netbeans, with 3 files currently open in the workspace - 2 java files and 1 jsp
Comment 15 cgmarroq 2009-12-14 07:17:56 UTC
Created attachment 92537 [details]
nps snapshot
Comment 16 cgmarroq 2009-12-17 10:42:17 UTC
Created attachment 92721 [details]
nps snapshot
Comment 17 sgtgarcia 2009-12-18 00:50:32 UTC
Created attachment 92738 [details]
nps snapshot

NetBeans starting up and opening projects
Comment 18 tapehead 2010-01-06 07:38:27 UTC
Created attachment 93098 [details]
nps snapshot

I was opening the IDE when this occured.  I have two projects that were in the project tree.  One large web project with several thousand files.  The other is a small java app with only 6 source files.
Comment 19 Jindrich Sedek 2010-01-21 02:18:00 UTC
This issue has over 200 duplicates, some of them spent waiting over 30s in org.openide.text.CloneableEditor$DoInitialize.initDocument method. It would be good to look at it as soon as possible.
Comment 20 Vitezslav Stejskal 2010-02-01 04:52:59 UTC
I looked at the few latest snapshots and it seems that this issue is mixing up several problems in different areas. The stacktraces end up in CloneableEditor$DoInitialize.initVisual(), but the call comes from different code, which tries to CE.getEditorPane() for whatever reason. The initialization code in CE is so complicated that I refuse to make any changes in it unless there is a P1 functionality problem. In this particular case, however, there is a possibility that the upper level code does not have to call CE.getEditorPane at all. This will require evaluating the snapshots one by one and analyzing the code in various modules that call CE.getEditorPane.
Comment 21 David Strupl 2010-02-11 07:17:17 UTC
I have looked at several (the most recent ones from the dev build) and they all involve

org.netbeans.modules.gototest.GotoOppositeAction.getCurrentFileType()

calling getEditorPane(). Who is taking care of gototest module nowadays?
Comment 22 Vitezslav Stejskal 2010-02-16 09:07:18 UTC
GotoOppositeAction is covered by issue #180595.
Comment 23 David Strupl 2010-03-12 05:39:57 UTC
I will try to evaluate some of the cases.
Comment 24 David Strupl 2010-03-15 12:52:19 UTC
I have tried to separate the recent reports into different issues (182013, 182017) and then asked Jindra Sedek to update the reporting to better search for duplicates. He adjusted the duplication detection to ignore the CloneableEditorSupport and report the more interesting cases separately.

I am closing this issue as it mixes different issues due to automatic duplicate detection. The new reports should be better searched for duplicates now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo