Bug 176335 - php debugging with xdebug proxy pydbgpproxy does not work: port 9000 is occupied
php debugging with xdebug proxy pydbgpproxy does not work: port 9000 is occupied
Status: RESOLVED INCOMPLETE
Product: php
Classification: Unclassified
Component: Debugger
6.x
PC Linux
: P3 with 1 vote (vote)
: TBD
Assigned To: rmatous
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-10 01:31 UTC by antonx
Modified: 2010-02-04 01:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description antonx 2009-11-10 01:31:35 UTC
I got a working xdebug on my suse linux 11.1 64 bit 
with netbeans dev/6.8 beta.

But I have a problem trying to use a xdebug proxy in my PHP project.

I downloaded from:
http://aspn.activestate.com/ASPN/Downloads/Komodo/RemoteDebugging

the file:
 
 Komodo-PythonRemoteDebugging-5.2.2-35694-linux-x86_64.tar.gz

I unpack it and run in the bin directory the file:
 
 pydbgpproxy

On the console I get the message:


mysuse:~/bin/pydbgp/bin> ./pydbgpproxy
INFO: dbgp.proxy: starting proxy listeners.  appid: 25000
INFO: dbgp.proxy:     dbgp listener on 127.0.0.1:9000
INFO: dbgp.proxy:     IDE listener on  127.0.0.1:9001

THE PROBLEM:
If I try now to debug with my netbeans I get a error dialog:

"Port 9.000 is already occupied. Configure IDE to use another port?"

I have configured:
In my php project-properties->Run-Configuration->Advanced 
I have set:

Debugger Proxy:
Host: 127.0.0.1
Port:9001 (the default)


---------------------

In my opinion Netbeans seems to do something wrong:
If the port 9000 is occupied and if I have a debug proxy
configured it should try to use the proxy.

In the case of a proxy, it obvious that the port will be
already opened by the proxy :-(
Comment 1 antonx 2010-02-04 01:51:57 UTC
The problem is that the Netbeans options are confusing:

- you must change in the netbeans options
  (which is netbeans wide)
  the xdebug port from 9000 to lets say 9001
  (as long as its not 9000 or 9001 which will be used by the proxy)

- you must set an ip in the *project* telling where  the proxy is.

If you switch between:

 1. using a proxy for debugging on a remote server
 2. not using a proxy to debug you local server

you end up changing the options continuously

There should be a switch somewhere 'use proxy'


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo