Bug 175763 - Deadlock opening file
Deadlock opening file
Status: RESOLVED DUPLICATE of bug 175637
Product: platform
Classification: Unclassified
Component: Text
6.x
All All
: P3 (vote)
: 6.x
Assigned To: mslama
issues@platform
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-30 12:43 UTC by Jesse Glick
Modified: 2009-10-30 13:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (8.80 KB, text/plain)
2009-10-30 12:43 UTC, Jesse Glick
Details
End of log file (5.93 KB, text/plain)
2009-10-30 13:17 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2009-10-30 12:43:22 UTC
091029 (09bc78a88eed). Used File > Recent File to open a Java source and IDE hung. Only activity is in EQ:

	at java.lang.Object.wait(Native Method)
	- waiting on <0x71883b28> (a org.openide.text.CloneableEditor$DoInitialize)
	at java.lang.Object.wait(Object.java:485)
	at org.openide.text.CloneableEditor$DoInitialize.initDocument(CloneableEditor.java:650)
	- locked <0x71883b28> (a org.openide.text.CloneableEditor$DoInitialize)
	at org.openide.text.CloneableEditor$DoInitialize.initVisual(CloneableEditor.java:688)
	at org.openide.text.CloneableEditor.getEditorPane(CloneableEditor.java:1185)
	at org.openide.text.CloneableEditorSupport.getOpenedPanes(CloneableEditorSupport.java:1098)
	at org.netbeans.modules.editor.hints.AnnotationHolder$1.run(AnnotationHolder.java:254)
Comment 1 Jesse Glick 2009-10-30 12:43:52 UTC
Created attachment 90280 [details]
Thread dump
Comment 2 mslama 2009-10-30 13:01:44 UTC
Do you have IDE log?
Comment 3 Jesse Glick 2009-10-30 13:17:30 UTC
Created attachment 90285 [details]
End of log file
Comment 4 mslama 2009-10-30 13:33:42 UTC
From IDE log it is clear. It was fixed yesterday evening.

*** This issue has been marked as a duplicate of 175637 ***
Comment 5 Jesse Glick 2009-10-30 13:44:53 UTC
Ah good, I filed an anagram. :-)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo