Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 175730 - null pointer exception while trying to add server
null pointer exception while trying to add server
Status: RESOLVED DUPLICATE of bug 150223
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
5.x
PC Linux
: P1 (vote)
: TBD
Assigned To: Petr Hejl
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-30 01:37 UTC by loren05
Modified: 2009-10-30 09:15 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
null pointer exception log (43.47 KB, text/plain)
2009-10-30 01:39 UTC, loren05
Details

Note You need to log in before you can comment on or make changes to this bug.
Description loren05 2009-10-30 01:37:33 UTC
null pointer exception was encountered while trying to add server



log:

java.lang.NullPointerException
	at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.ServerChooserVisual.isServerValid(ServerChooserVisual.java:109)
	at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.ServerChooserVisual.isValid(ServerChooserVisual.java:101)
	at java.awt.Component.invalidateIfValid(Component.java:2787)
	at java.awt.Component.setLocale(Component.java:1857)
	at javax.swing.JComponent.<init>(JComponent.java:595)
	at javax.swing.JPanel.<init>(JPanel.java:65)
	at javax.swing.JPanel.<init>(JPanel.java:92)
	at javax.swing.JPanel.<init>(JPanel.java:100)
	at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.ServerChooserVisual.<init>(ServerChooserVisual.java:48)
	at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.ServerChooserPanel.getComponent(ServerChooserPanel.java:44)
	at
org.netbeans.modules.j2ee.deployment.impl.ui.wizard.AddServerInstanceWizard$AddServerInstanceWizardIterator.initialize(AddServerInstanceWizard.java:196)
	at org.openide.WizardDescriptor.callInitialize(WizardDescriptor.java:1177)
	at org.openide.WizardDescriptor.<init>(WizardDescriptor.java:361)
	at org.openide.WizardDescriptor.<init>(WizardDescriptor.java:371)
	at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.AddServerInstanceWizard.<init>(AddServerInstanceWizard.java:63)
	at org.netbeans.modules.j2ee.deployment.impl.ui.wizard.AddServerInstanceWizard.<init>(AddServerInstanceWizard.java:50)
	at org.netbeans.modules.j2ee.deployment.impl.ui.ServersCustomizer.addServer(ServersCustomizer.java:294)
	at org.netbeans.modules.j2ee.deployment.impl.ui.ServersCustomizer.access$000(ServersCustomizer.java:66)
	at org.netbeans.modules.j2ee.deployment.impl.ui.ServersCustomizer$1.actionPerformed(ServersCustomizer.java:166)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.Component.processMouseEvent(Component.java:6263)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6028)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
[catch] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:178)
	at java.awt.Dialog$1.run(Dialog.java:1045)
	at java.awt.Dialog$3.run(Dialog.java:1097)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1095)
	at org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:816)
	at org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:859)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:847)
	at org.openide.util.Mutex.doEventAccess(Mutex.java:1178)
	at org.openide.util.Mutex.readAccess(Mutex.java:215)
	at org.netbeans.core.windows.services.NbPresenter.show(NbPresenter.java:832)
	at java.awt.Component.show(Component.java:1563)
	at java.awt.Component.setVisible(Component.java:1515)
	at java.awt.Window.setVisible(Window.java:841)
	at java.awt.Dialog.setVisible(Dialog.java:985)
	at org.netbeans.modules.j2ee.deployment.devmodules.api.ServerManager.showCustomizer(ServerManager.java:68)
	at org.netbeans.modules.j2ee.deployment.impl.ui.actions.ServerManagerAction.performAction(ServerManagerAction.java:39)
	at org.openide.util.actions.CallableSystemAction$1.run(CallableSystemAction.java:100)
	at org.netbeans.modules.openide.util.ActionsBridge.doPerformAction(ActionsBridge.java:53)
	at org.openide.util.actions.CallableSystemAction.actionPerformed(CallableSystemAction.java:96)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1225)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1266)
	at java.awt.Component.processMouseEvent(Component.java:6263)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6028)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 1 loren05 2009-10-30 01:39:32 UTC
Created attachment 90255 [details]
null pointer exception log
Comment 2 Petr Hejl 2009-10-30 09:15:09 UTC

*** This issue has been marked as a duplicate of 150223 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo