Bug 175347 - NullPointerException at org.netbeans.modules.project.ui.ProjectsRootNode$BadgingNode.replaceProject
NullPointerException at org.netbeans.modules.project.ui.ProjectsRootNode$Badg...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@projects
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: ERGONOMICS, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-23 23:49 UTC by dnorton17
Modified: 2009-11-11 01:56 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.64 KB, text/plain)
2009-10-23 23:49 UTC, dnorton17
Details
stacktrace (1.73 KB, text/plain)
2009-10-24 00:52 UTC, evandro1979
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dnorton17 2009-10-23 23:49:17 UTC
Build: NetBeans IDE 6.8 Beta (Build 200910212001)
VM: Java HotSpot(TM) Client VM, 1.5.0_19-137, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_19-b02-304
OS: Mac OS X, 10.5.7, i386

User Comments:
jvaldes: scan projectss

cesr42: On initially starting 6.8 beta for the first time, I closed the Start Page tab and got this error.

GUEST: Occured upon first start of IDE. Did an import of my previous 6.5 settings.

dnorton17: Opening Netbeans 6.8 beta for the first time after importing settings from 6.7.1



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.project.ui.ProjectsRootNode$BadgingNode.replaceProject(ProjectsRootNode.java:515)
        at org.netbeans.modules.project.ui.ProjectsRootNode$BadgingNode.access$000(ProjectsRootNode.java:428)
        at org.netbeans.modules.project.ui.ProjectsRootNode.checkNoLazyNode(ProjectsRootNode.java:209)
        at org.netbeans.modules.project.ui.OpenProjectList$LoadOpenProjects.run(OpenProjectList.java:320)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1084)
Comment 1 dnorton17 2009-10-23 23:49:25 UTC
Created attachment 90032 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-10-23 23:49:30 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=159990
Comment 3 evandro1979 2009-10-24 00:52:23 UTC
Build: NetBeans IDE 6.8 Beta (Build 200910212001)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments: 
Thas show in my first use of the NetBeans IDE 6.8 Beta, I import the configs of the NetBeans IDE 6.7.1.

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.project.ui.ProjectsRootNode$BadgingNode.replaceProject(ProjectsRootNode.java:515)
        at org.netbeans.modules.project.ui.ProjectsRootNode$BadgingNode.access$000(ProjectsRootNode.java:428)
        at org.netbeans.modules.project.ui.ProjectsRootNode.checkNoLazyNode(ProjectsRootNode.java:209)
        at org.netbeans.modules.project.ui.OpenProjectList$LoadOpenProjects.run(OpenProjectList.java:320)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1084)
Comment 4 evandro1979 2009-10-24 00:52:28 UTC
Created attachment 90035 [details]
stacktrace
Comment 5 Exceptions Reporter 2009-10-24 00:52:34 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=159990
Comment 6 Exceptions Reporter 2009-10-24 13:29:42 UTC
This issue already has 12 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=159990
Comment 7 Exceptions Reporter 2009-10-25 11:18:00 UTC
This issue already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=159990
Comment 8 Milan Kubec 2009-10-26 10:52:42 UTC
So far not able to reproduce.
Comment 9 Milan Kubec 2009-10-27 11:46:55 UTC
Added check for null. Original problem (unknown to me) is probably still there.

http://hg.netbeans.org/core-main/rev/12d684c13733
Comment 10 Quality Engineering 2009-10-28 11:52:43 UTC
Integrated into 'main-golden', will be available in build *200910280201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/12d684c13733
User: Milan Kubec <mkubec@netbeans.org>
Log: #175347: check for null added
Comment 11 Milan Kubec 2009-10-29 14:38:19 UTC
Reopening for further evaluation.
Comment 12 Milan Kubec 2009-10-29 14:39:39 UTC
Jardo, please re-evalaute the issue. Thanks.
Comment 13 Jaroslav Tulach 2009-11-03 09:59:43 UTC
The NPE seems to be fixed by Milan. I am not sure what else I am supposed to do. I could write a test, but I do not 
really feel inspired by reproducing bug that cannot appear anymore. But if anyone wants, feel free to simulate the 
NPE. I can imagine it could happen when one restarts and some originally open project is no longer recognizable as 
project and thus ProjectManager.getDefault().findProject returns null.
Comment 14 Jaroslav Tulach 2009-11-03 10:00:48 UTC
Fixed in 12d684c13733
Comment 15 Antonin Nebuzelsky 2009-11-04 10:49:02 UTC
Reopening as was discussed with jtulach offline. Removing RANDOM, adding REGRESSION.

This seems like much more severe problem than just a project which is not recognizable as a project after restart. So,
catching this NPE only hides the problem which is still there.

My assumption is based on the fact that this NPE is reported by many users of 6.8 Beta, and before beta there were no
such reports. See http://statistics.netbeans.org/exceptions/detail.do?id=159990
Comment 16 Antonin Nebuzelsky 2009-11-04 10:50:39 UTC
Jarda will evaluate.
Comment 17 Jaroslav Tulach 2009-11-05 08:47:55 UTC
All last ten reports contain ERGO_PROJECT_OPEN soon after start. This seem to imply there is a problem during import 
of existing user director when starting with new version. Many of the reports open project type from enterprise 
cluster. The exception is thrown sooner than the enterprise modules are enabled however.
Comment 18 Jaroslav Tulach 2009-11-11 01:56:21 UTC
core-main#3e4b60867331


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo