Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 175233 - 4s - editor.settings.storage.StorageImpl.load()
4s - editor.settings.storage.StorageImpl.load()
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Settings
6.x
PC Linux
: P3 with 1 vote (vote)
: TBD
Assigned To: Milutin Kristofic
issues@editor
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 192182 195539 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-22 18:32 UTC by Michel Graciano
Modified: 2013-07-30 13:46 UTC (History)
36 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-16 11:25 UTC, pansapien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2009-10-22 18:32:36 UTC
Build: NetBeans IDE Dev (Build 200910170201)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Linux, 2.6.28-16-generic, i386
User comments: 
Maximum slowness yet reported was 20391 ms, average is 10304
Comment 1 Stanislav Aubrecht 2009-10-23 07:15:39 UTC
org.netbeans.ProxyClassLoader.loadClass() is slow
Comment 2 pansapien 2009-11-16 11:25:36 UTC
Created attachment 91117 [details]
nps snapshot
Comment 3 Exceptions Reporter 2009-11-16 11:25:43 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=158187
Comment 4 Exceptions Reporter 2009-11-18 05:14:20 UTC
This issue already has 9 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=158187
Comment 5 Jaroslav Tulach 2011-04-13 13:31:34 UTC
The snapshot:
http://statistics.netbeans.org/exceptions/exception.do?id=500814
shows that org.netbeans.modules.editor.settings.storage.StorageImpl.load() is blocked by long running save (which includes also compilation of XSL scripts). The  critical section in save could be made smaller, I am sure.
Comment 6 Milutin Kristofic 2011-09-19 15:21:47 UTC
*** Bug 192182 has been marked as a duplicate of this bug. ***
Comment 7 Milutin Kristofic 2011-09-19 15:27:04 UTC
*** Bug 195539 has been marked as a duplicate of this bug. ***
Comment 8 Milutin Kristofic 2013-07-30 13:46:29 UTC
They are many irrelevant snapshots in this issue. There is no plan to make StorageImpl.save faster, since it is sufficently fast and improvement has not good ratio of effort/benefit.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo