Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 175196 - Install from UC is tricky
Install from UC is tricky
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
Macintosh Mac OS X
: P2 (vote)
: 6.x
Assigned To: dlipin
au-issues
67patch2-fixed
:
: 169212 174048 178175 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-22 11:29 UTC by Lukas Hasik
Modified: 2010-02-22 03:56 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
logs (4.94 KB, application/x-gzip)
2009-11-27 03:21 UTC, Michael Nazarov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2009-10-22 11:29:37 UTC
Product Version: NetBeans IDE 6.8 Beta (Build 200910212001)
Java: 1.6.0_15; Java HotSpot(TM) 64-Bit Server VM 14.1-b02-92
System: Mac OS X version 10.5.8 running on x86_64; MacRoman; en_US (nb)
Userdir: /Users/lukas/.netbeans/6.8beta

Scenario:
- install a distro without Java FX plugins
- Tools > Plugins > Available Plugins
- Check the "Java FX Kit" plugin and "Install". (DO NOT check weather sample)
- let the IDE restart

What happens?
1, IDE restarts and the "Warning - could not install some modules:
	org.netbeans.modules.javafx.weather2 - The module org.netbeans.modules.javafx.kit would also need to be installed.
	org.netbeans.modules.javafx.kit - The module named org.netbeans.modules.javafx.sdksamples was needed and not found."
dialog appears

2a, choose "Disable and Continue" -> FX isn't installed
2b, choose "Exit" -> IDE restart again and the FX functionality is there

Anyway, neither 2a nor 2b is the problem the root problem is the 1. Probably some wrong dependencies?
If you check "Java FX Kit" + "JavaFX Weather Sample" then it installs correctly.
This is Mac specific. I was not able to reproduce on Vista, Win7. As it is somekind of corner case with easy workaround
I'm not marking it as stopper for Beta.
Comment 1 Andrei Chistiakov 2009-10-22 12:08:22 UTC
I could not reproduce this with Java SE distribution either on Windows XP or Linux.
Comment 2 dlipin 2009-10-27 12:33:38 UTC
please attach /Users/lukas/.netbeans/6.8beta/var/log/messages.log* files.
Comment 3 dlipin 2009-10-29 12:40:35 UTC
core-main#d320eae95799
Comment 4 Quality Engineering 2009-10-30 11:05:41 UTC
Integrated into 'main-golden', will be available in build *200910300201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d320eae95799
User: Dmitry Lipin <dlipin@netbeans.org>
Log: Issue #175196 Install from UC is tricky
Comment 5 dlipin 2009-10-30 11:16:47 UTC
*** Issue 174048 has been marked as a duplicate of this issue. ***
Comment 6 Michael Nazarov 2009-11-27 03:20:41 UTC
Reproduced as in my original issue, with "needed and not found" error message.
Check my logs from Linux. MacOS failed to install as well BTW.
Comment 7 Michael Nazarov 2009-11-27 03:21:57 UTC
Created attachment 91762 [details]
logs
Comment 8 dlipin 2009-11-27 03:27:44 UTC
> Reproduced as in my original issue
what is your original issue? Please describe exact steps starting with clean userdir to reproduce it. Which bundle, which plugins selected to install, etc
Comment 9 Michael Nazarov 2009-11-27 03:31:59 UTC
It was you who marked my issue as duplicate and link to is in the comments :)
https://netbeans.org/bugzilla/show_bug.cgi?id=174048
As I wrote I use clean dir each time and installs all available plugins. Just Ctrl+A then install then restart.
Comment 10 Michael Nazarov 2009-11-27 04:29:47 UTC
Checked once again:

Warning - could not install some modules: Scan On Demand - The module named org.netbeans.modules.parsing.api was needed and not found.
Comment 11 dlipin 2009-11-27 04:33:57 UTC
Did you by chance run NB from console? was there any warning there?
I`m installing the plugins to make sure that I experience the same issue as well.
Comment 12 Michael Nazarov 2009-11-27 04:36:32 UTC
Yes, it was started from console. Nothing interesting.
Comment 13 dlipin 2009-11-27 05:10:56 UTC
Seems to be unrelated, I have filed separate Issue 177737.
Comment 14 dlipin 2009-12-08 11:13:38 UTC
*** Bug 178175 has been marked as a duplicate of this bug. ***
Comment 15 dlipin 2009-12-09 11:19:12 UTC
*** Bug 169212 has been marked as a duplicate of this bug. ***
Comment 16 Marian Mirilovic 2009-12-17 04:36:06 UTC
Lukasi/Michael, 
could you please verify the fix that is available on testing UC:
http://smetiste.czech.sun.com/builds/netbeans/6.7.1/fixes/2009-12-14_12-38-21/ml/uc/catalog.xml.gz
? 
Thanks you very much.
Comment 17 Lukas Hasik 2009-12-17 05:50:28 UTC
verified, after updating the IDE from the staging UC the JavaFX Kkit module can be installed correctly
Comment 18 pgebauer 2009-12-21 06:20:59 UTC
Just for the record, the info about port to the release_67 fixes branch is available at https://netbeans.org/bugzilla/show_bug.cgi?id=178175#c10
Comment 19 dlipin 2010-02-02 07:42:41 UTC
Petr (Gebauer),

Is the fix to this issue already published to UC?

I can`t see it at the patches info page
http://wiki.netbeans.org/NetBeans6.7PatchesInfo

However I see the corresponding in module in staging area
http://updates.netbeans.org/netbeans/updates/6.7.1/uc/final/stable/_staging_/platform10/org-netbeans-modules-autoupdate-services.nbm

Do you know by chance when it would be published? Or should I ask Robert about that?

Thanks,
Dmitry
Comment 20 pgebauer 2010-02-22 02:04:44 UTC
The fix should be published on the NetBeans 6.7.1 AUC already.
Comment 21 rbalada 2010-02-22 03:56:37 UTC
I've added info about it to the Patches Info page.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo