Bug 174881 - Smart secure copy: don't override generated files with local changes
Smart secure copy: don't override generated files with local changes
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Vladimir Kvashin
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-19 13:57 UTC by Vladimir Kvashin
Modified: 2010-02-09 16:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2009-10-19 13:57:45 UTC
There sometimes are some files (makefiles and source files) that are generated on remote host.
In some situations these remotely generated files are overridden by local ones.

Consider a autoconf project that already contains Makefile (generated locally). If you switch it to remote mode and try
configuring it on remote host (either "manually" via shell, or with the help of the IDE) prior than you try building it,
then, upon buld, makefile that is generated on remote host, will be overridden with one copied from local host.

In the case project contains some generated source files, we'll have the same situation.
Comment 1 Alexander Pepin 2009-10-30 16:47:12 UTC
looks like a duplicate of issue #172138.
please evaluate.
Comment 2 Vladimir Kvashin 2009-11-13 08:22:19 UTC
To fix this I need to change rfs preload and controller logic a bit.
Comment 3 Vladimir Kvashin 2010-02-09 16:31:22 UTC
Fixed by numerous schangesets (the last one is http://hg.netbeans.org/cnd-main/rev/d3cb9cd874ab)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo