Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 174863 - Run into method in anonymous class gets debugger into a strange state
Run into method in anonymous class gets debugger into a strange state
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All Windows Vista
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-19 11:02 UTC by Vojtech Sigler
Modified: 2009-10-27 13:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vojtech Sigler 2009-10-19 11:02:05 UTC
Product Version: NetBeans IDE Dev (Build 200910170201)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)

1) Open MemoryView project (http://qa.netbeans.org/modules/debugger/promo-h/MemoryView.zip), open file MemoryView.java
2) Place cursor on line 58 and invoke run to cursor
3) put cursor on line 62 on the call "updateStatus();"
4) invoke Run Into Method
5) Now shows all threads as running, but the application is not running, no action visible, debugger console says "User
program running", in the debug toolbar there are four buttons enabled - stop, pause, run to cursor and apply code changes.

Workaround is only to restart debugging session. Run to cursor invokes a new debugging session.
Comment 1 Vojtech Sigler 2009-10-19 11:02:43 UTC
Forgot to add, there are no error messages in the log.
Comment 2 Martin Entlicher 2009-10-19 14:07:46 UTC
Maybe this is already reported in issue #174849 - I'll check this after that issue is fixed.
Comment 3 Vojtech Sigler 2009-10-19 14:24:37 UTC
I found that issue before and it looks similar, but I cannot tell if it is the same. Reported just to be sure. :)
Comment 4 Vojtech Sigler 2009-10-19 14:36:58 UTC
Since it is confirmed that this is a duplicate of #174849, I consider this a stopper for beta.
Comment 5 Vojtech Sigler 2009-10-19 14:38:33 UTC
Pardon, a typo: This is NOT yet confirmed as a dup of #174849.
Comment 6 Martin Entlicher 2009-10-20 08:28:57 UTC
After the fix of issue #174849 debugger does not get into that strange state any more. But "Run Into Method" does not
really work well in this case. It does not step into that method for me. Might be because the Timer class is not
initialized yet... I'm going to explore...
Comment 7 Vojtech Sigler 2009-10-20 13:40:56 UTC
Debugger lockups disappeared after fix of issue #174849, but debugger still fails to run into a method in an inner
class. However, since this is not a frequent usecase, I no longer consider this a stopper for beta. Making this a P2.
Comment 8 Martin Entlicher 2009-10-20 17:03:33 UTC
O.K.
There's also another problem - the method we're running into is going to be executed in another thread - in the Timer
thread. Thus this needs additional change in the logic.
Comment 9 Martin Entlicher 2009-10-21 15:53:15 UTC
Fixed in changeset:   150249:8099a910d418 and changeset:   150250:c97ee7f5d8da

http://hg.netbeans.org/main/rev/8099a910d418
http://hg.netbeans.org/main/rev/c97ee7f5d8da
Comment 10 Quality Engineering 2009-10-22 23:52:07 UTC
Integrated into 'main-golden', will be available in build *200910221401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8099a910d418
User: mentlicher@netbeans.org
Log: #174863 - Make Run Into Method to work for sub-classes.
Comment 11 Vojtech Sigler 2009-10-27 13:06:45 UTC
Verified in trunk build 200910270201


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo