Bug 174527 - Cannot build Web/J2EE project
Cannot build Web/J2EE project
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P1 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
: SPACE_IN_PATH
: 174568 174577 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-14 11:29 UTC by Martin Schovanek
Modified: 2009-10-15 10:27 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2009-10-14 11:29:26 UTC
[#200910130201, jdk1.6, Win Vista, GF v3, J2EE 6]

to reproduce:
-------------
1) install Nb into the default location ("C:\Program Files\NetBeans Dev 200910130201")
2) create a new Web Project with a Servlet
3) clean and build the project

ERROR: build fails due:
...
Compiling 1 source file to C:\Users\felipee\Documents\NetBeansProjects\WebApplication2\build\web\WEB-INF\classes
javac: invalid flag: Files\NetBeans
Usage: javac <options> <source files>
use -help for a list of possible options
...

Java SE project is working fine.
Comment 1 Petr Jiricka 2009-10-14 17:24:12 UTC
This may be related to David's recent changes for endorsed dirs etc. Martin, could you please switch Ant to verbose mode
and run it again, and attach the output? That may contain some more diagnostic information. Thanks.
Comment 2 David Konecny 2009-10-14 19:26:46 UTC
Yes, filenames with spaces are not handled properly.
Comment 3 David Konecny 2009-10-14 19:27:11 UTC
*** Issue 174568 has been marked as a duplicate of this issue. ***
Comment 4 David Konecny 2009-10-14 19:27:25 UTC
*** Issue 174577 has been marked as a duplicate of this issue. ***
Comment 5 David Konecny 2009-10-14 19:52:46 UTC
49624dc91b87
If NetBeans is installed in folder with a space in the name then JEE6 projects will fail to build because endorsed jars
were not handled properly in build script.
Comment 6 Quality Engineering 2009-10-15 10:27:22 UTC
Integrated into 'main-golden', will be available in build *200910150201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/49624dc91b87
User: David Konecny <dkonecny@netbeans.org>
Log: #174527 - spaces in path name were not properly handled


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo